Bug with Print Out in Worksession

I’ve reported print out bug in worksession 8 month ago. Looks like same bugs still goes on.

They are printed in reference file with no problem

Overhead lines are not printed in worksession.

Slanted Column_Reference.3dm (2.5 MB)

Rhono 7.22
Visualarq 2.12.6


Hi @archist97,

I tried with those versions and it is working fine. Please, make sure you have the worksession file in the same units as the reference file.

There is no problem with unit setting. The reference file and worksession file are set to same unit - mm.
Print Out Error

Hi @archist97,

Ok, I think what is happening is that it is being printed in white. If you change the “Line Print Color” of this beam in the original file to a different color it should display well.

Actually, the overhead print color should be taken from the Rhino Options in the file where you have the worksession, so I’ll report this in order to fix it (in the meantime you can change the colour as I told you above).

No, this is not a problem with print color in the rhino option. It is set to black.
You can see overhead lines are printed out with no problem in reference file.
Setting in worksession file is also is black.
You are saying exactly same thing that you guys talked about 8 month ago ( unit setting, print color setting in Rhino Option). This error is not related with unit setting and overhead option in Rhino option.

Meanwhile, I found out another bug with Worksession
I tried to open worksession file in which the reference I’ve posted was attached, but no geometry are shown up. There is no layers in a worksession layer, either.

Open WS Error

Hi @archist97,

They are printed fine in the reference file because it is taking the attributes from that file. In the worksession file, even if you set the overhead print color to black it will not be printed this way because it looks like it is always taking the object display colour.

Please, change the beam projection “Line print color” in the original file; this should make your beam visible when you print in the worksession (now it is being printed in white). If this doesn’t fix the issue maybe we could meet in a zoom meeting to check it in your computer; please, let me know about it.

Please, send us all the worksession files so that we can reproduce the same issue. We’ll check what is happening.

Alfonso. Your trick works and I tried same trick in other worksession file and I noticed that same problem happens with display color for projection and overhead as well in worksession. I hope this bugs will be fixed in next service release version.

When it comes to error with opening worksession file, the problems is gone after I changed print color to black in the reference file manually.


Hi @archist97,

Ok, I have already reported this error, I’ll keep you updated about it.

Hi. Alfonso.
I’ve tested VA 2.13 internal version today. Seems like this issue still persists.
Is this bug not fixed in the new version?

Hi @archist97 we are still pending to fix this error for VisualARQ 2.13. We will let you know when we fix it.

Hi @archist97 the issue is fixed in the public version of VisualARQ 2.13. VisualARQ 2 - Version 2.13 released