Bug using Rhino 7 with function "Apply Edge Softening"

Hi!
It was very easy to use in Rhino 6 the function “Apply Edge Softening”: we only had to go to the render window, and then, click on the icon “Apply Edge Softening”, and define the softeness. Now, the window and the way to do this has changed: first, we have to select the mesh, after, tape Enter, and then, at the right corner, a new windows opens, where we have to put “Activé” to do the function, and after, we have to say “forcer l’adoucissement”. This is more complicated that in the version 6 of Rhino, but, the worst is that i can do this, everytimes, at this moment, my Rhino crashes, and i have a good computer.
Can you please explain me why, and we we have to do against this?
Thanks so much! :slight_smile:

Please run the Rhino SystemInfo command and post the results, so we can see the counter resources Rhino is detecting.

Thanks

1 Like

Hi

Thanks

This is this:

Rhino 7 SR11 2021-10-12 (Rhino 7, 7.11.21285.13001, Git hash:master @ ca75d3c67ded62b7ad8856f48d5ef2d6d1d926be)
License type: Commerciale, version 2021-10-12
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 (NVidia) Memory: 8GB, Driver date: 11-22-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 457.51
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-22-2020
Driver Version: 27.21.14.5751
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.11.21285.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.11.21285.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.11.21285.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.11.21285.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.11.21285.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.11.21285.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.11.21285.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

In Options > Plug-ins, disable V-Ray and restart Rhino.
Any better?

1 Like

Hi

No, i just come to disable Vray, and then, restart Rhino, and when i click on “Activé” for the command “Apply Edge Softening”, then, it tooks a lot of time searching, and then, the screen is white like a crash or a beug…

Hello- is this true in any file, or just some? Can you make it work properly in a new file with just a box?
(Running the command should not bring up any panel or dialog, all the settings should be at the command line.)

-Pascal

1 Like

Hi Pascal, with only a box it is ok.
I am afraid my meshes files is very complex, and i have to find how to do that the meshes has less complexity in Rhino…

You may have bad meshes or bad objects. I would check them with the following commands: ShowEdges, Check, SelOpenPolysrf, SelSrf, SelBadObjects, ExtractBadSrf.

MeshRepair and RebuildMesh commands may be used to repair bad meshes. If the meshes are very complex, you may have to use different program than Rhino to repair them.

Meshmixer and MeshLab are free mesh cleaners and mesh editors. They are equally popular. MeshLab has more features, but it is more buggy.

CloudCompare is free point cloud and mesh editor.
download: CloudCompare - Downloads
short video: Review: What can you do with CloudCompare open source software? | 3D Forensics useful tools - YouTube

TopoGun mesh editor ($100) is fast. video: TopoGun - Introduction on Vimeo

Geomagic ($8,000 to $30,000) and PolyWorks ($10,000 to $30,000) can import gigabyte-size meshes.

VirtualGrid VRMesh ($695) can also handle large meshes.

1 Like

Hi -

I suppose that could simply indicate that Rhino is very busy working on it. When you check the Rhino process in the Windows Task Manager, is it still working?
-wim

1 Like

Hi Andrew, thanks so much! I will check to this! :slight_smile:

Hi Wim, i will try this, but i tried waiting around five minutes, so, i am afraid there is a bug!

Hi -

The only way we can check this is if you post the file and steps to reproduce.
-wim

1 Like

Hi Wim
Thanks so much
Here you have the file :slight_smile:
04RHINO Voronio Lampe_PourSTL.3dm (8.1 MB)

Hello- thanks, I am looking at it now… I see a lag as well, even after some mesh cleanup.

@kostaldeak - you can try:

  1. RebuildMesh
  2. Weld at say 45 degrees
  3. Select the mesh, set softening at .25 and apply (at .5 it will not do it)
    You will need to wait, but it gets there. I do not know if this delay is expected, in the current state of things – I seldom use edge softening on meshes (as disitinct from polysurfaces) myself but I’ll ask the developers.

-Pascal

1 Like

Hi Pascal, thanks so much!
Sandrine