Bug report: Variable radius chamfer


#1

Rhino V5 for mac release 2014 02 18

computer:
Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-02-18 (503)
OS X version: Version 10.9.1 (Build 13B42)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: iMac12,2
Processor: Intel Core i5-2500S CPU @ 2.70GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon HD 6770M 512 MB
Memory: 512 MB
Screen size: 2560 x 1440
Displays: iMac

USB devices
Apple Computer, Inc.: IR Receiver
Apple: Internal Memory Card Reader
Apple Inc.: FaceTime HD Camera (Built-in)
Logitech: USB Optical Mouse
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.14.21
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: None
Mip map filtering: None
Anisotropic filtering: None


Variable radius chamfer and filet not accurent! chamfer annotation viewing problem see picture above


Ps: tx for the good job you did on the ergonomy of the new interface.
keep up the good work


(Brian James) #2

Thanks for this report on what you’re seeing when using FilletEdge and ChamferEdge. I am not able to reproduce it here however in the same OSX and Rhino builds. My hunch so far is that it is specific to this GPU make and model. @marlin do you know of issues with this card?


(Marlin Prowell) #3

No, this is not GPU related. Can you post your model, please, so we can duplicate your problem?


#4

sure;

I want to filet the 3 inside edges of this door frame
_chamfer 5 cm on the 3 edges
_radius 3 cm on the 3 edges
the tools failed to create clean straight chamfer or filet.

BUG 01.3dm (233.9 KB)


#5

can you describe how you’re creating the door frame? that’s where the problem lies(I think)… you have single surfaces bending around what should be sharp edges.


(Chuck Welsh) #6

Yes, the problem is that the surfaces are not split up at the creases. That said, we should handle this differently, since the ChamferEdge interface makes it seem like there is nothing wrong. You can see how bad this really is by just picking one of those sides. The resulting chamfer goes all the way around anyway. I’ll make a bug report for this.

For now, you can get rid of the problem by calling “DivideAlongCreases” before chemfering. You also might want to run “CreaseSplitting” to see if you have changed the default behavior sometime in the past. When you run the command, if you see “Split creased surfaces into smooth polysurfaces ( SplitAlongCreases=No ):” , click the no to make it a yes, and you should not get this problem next time you create the pre-chamfered object.


#7

How I did the door frame?
I draw one closed curve, then extrude it solid, then I apply chamfer on the 3 inside edges. Very Simple indeed.
I am pretty sure it is a bug, as I often do this operation with precedent version of rhino without any troubles.

Tx Chuck for the tip. I have to try this!


#8

it’s probably not a bug… do what chuck said. (it’s not exactly the same on mac)

run the command CreaseSplitting
check Split Along Creases
click Done

redraw your door frame and try the chamfer again…
does it fix the problem?

for instance- here’s your file but i drew another door frame with default settings… run ChamferEdge and FilletEdge on these edges and you’ll get the results i think you’re after.

BUG 01-2.3dm (635.9 KB)


#9

problem solved with the new release (504)
thanks for the good job guys!