BUG: Notes tab loses focus. Text input (and shortcuts like Ctrl+V) go to command line instead

I’m trying to type notes in a Rhino file using the Notes tab.
Right now I cannot even type anything there anymore.

Closing the tab and reopening does not fix the problem.
Closing Rhino and relaunching it is the only solution.

It happens very frequently but still have not figure out how to make it repeatable. I think the Enter key (to move to the next line of text) might be causing it sometimes.



i reported this a while ago and i thought it got fixed huh

6 years ago! I don’t use notes that often, but for use I’ve used them many times in the last 6 years amd I’ve never seen this before.

BoxEdit also continues to have problems of not being active. I wonder if they are related.


Well the last entry on the bug report - release target 7.1 - says that the tester couldn’t repeat the problem:


So if you have a reproducible way to make this happen, post it here.

i haven’t been able to reproduce it consistently. :frowning:

i just went and tried to find a way to trigger it, i copied some text and went to paste it and it triggered the bug. maybe repeatable?

Here’s my recipe:

  • Copy some existing text to the Windows clipboard from somewhere
  • Open a new V7 Rhino file, paste the text into the Notes panel
  • You should be able to select the text and edit it.
  • Go back into the Rhino window and run a command (say, circle)
  • Go back to the Notes window and select some of the text and hit the delete key on the keyboard
  • It doesn’t delete, but Delete gets printed to the command line.
  • The Notes window is more or less frozen, you can’t do anything in it.
  • Any keystrokes entered while in the Notes window go to the command line. If you press Enter it repeats the last Rhino command.
  • If you play around some more between the Rhino main window and the Notes window, it will start working again.

It’s repeatable, here is a second one done just after:

Rhino 7 SR1 2020-11-9 (Rhino 7, 7.1.20314.23101)



you never cease to amaze us! :+1:

followed your recipe and it is repeatable here

Good, if they can repeat it, they can fix it. The bugtrack item above has been reopened, says target 7.2 currently.

1 Like

good deal.

@John_Brock @JohnM - note that this does not appear to be entirely fixed, I just had it happen in my current 7.2 RC (7.2.20343.11011, 08-Dec-20) - I am trying to figure out a way to reproduce it consistently - in this case there was no pasting of anything into the notes panel, but at some point all the Notes panel input went to the command line again. I fixed it by switching tabs to something else and then back to notes. Will try to create a ‘recipe’. There is also this post that just appeared, but they may be on 7.1.

Edit - it turned out to be surprisingly easy to reproduce… so either it isn’t fixed yet in the version I have, or it somehow got ‘unfixed’. (7.2.20343.11011, 08-Dec-20)


  • In my case Layers, Notes, and MacroEditor are panels docked together on the right hand edge.
    (i.e. as separate tabs)
  • Launch Rhino with a new blank default template (with Layers as the active tab)
  • Click on the Notes tab to make it active
  • Type the following on one line in Notes: This is a test
    (Do not press Enter, leave the cursor at the end of the line.)
  • Go back to the Rhino window and choose a tool, say Rectangle - make the rectangle.
  • Go back to the Notes panel and click to place the cursor at the end of the test line.
    (note the cursor is flashing in the Notes panel, indicating it is active)
  • Hit Enter as if you want to start a new line in Notes.
  • The Rectangle command will be launched instead.

i repeated it with your recipe.

i only have layers, properties, boxedit, notes, and macro editor open.

I did some more digging and was able to isolate and fix the problem. The fix will be available in the next public build.


nice! thank you

This does appear to be fixed in the latest 7.2 RC - (7.2.21005.13001, 05-Jan-21)