Bug focusing in grasshopper or Rhino

Hello To all dear subscribers
I have read that some people have the same problem as I have while working in a window in grasshopper suddenly all typing and commands are written in command line of rhino even delete key don’t work and it is writing in the command line in rhino and because of my code is really heavy and take a lot of time to load it is getting me really crazy… does any one have a solution?

Maybe you can post your SystemInfo
I remember having these issues but haven’t seen them for quite some time. Do you have multiple instances of Rhino running?
It still happens every now and then when I am using python editor (outside grasshopper)
Sometimes I remember I could fix it by going to another application and then switching back to Rhino.

1 Like

Hi dear Gijs
Thank you so much paying attention to my problem and answering me and I should say no unfortunately I have just one instance of rhino working on it and I have tried all of these tricks as you said but unfortunately none of them worked … I want to explain my work in thesis for my teacher and suddenly it is happening and it takes a long time to reload it …
and I have windows 10 and rhino 6… I don’t know what other specification needed I say?

Type _SystemInfo in Rhino and post back the results. Sometimes people here can spot issues in your system settings that might need attention

1 Like

Rhino 6 SR25 2020-4-23 (Rhino 6, 6.25.20114.05271, Git hash:master @ f35d7ded15ec317635ced435d8df84327397038d)
License type: Commercial-, build 2020-04-23
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: ASUS

Hybrid graphics system.
Primary display: Intel® HD Graphics 4000 (Intel) Memory: 2GB, Driver date: 12-21-2015 (M-D-Y).
Primary OpenGL: NVIDIA GeForce 610M (NVidia) Memory: 2GB, Driver date: 12-4-2017 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 388.57

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-4-2017
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\alireza\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.6.14.669\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”

If anything it’s always good to keep your display drivers up to date they are from 2015 and 2017 so an update would not hurt.

Hi dear willem
Thank you for reply but I don’t know how to update them I know that it is really embarassing :sweat_smile:

What version of Vray do you have?
And yes if possible try to update your video drivers. I am sure you have a friend or come student that can help you with this

I also see that you have other issues with grasshopper. I would try to disable them all and see if the problem persists, if not enable them one by one until the problem reappears. Also make sure your windows is up to date.

Hi dear friend
Does it Effective while I don’t use it? and the wndows is u to date I am sue but do not know how to update the video drivers… I will search and do it … and about the second message and with enabling and disabling issues I dont know how can I find out where is the problem

If you don’t use it it is still loaded. Try disabling Vray just to rule things out.

Which grasshopper plugins do you have installed?

lots of plug- ins actually :sweat_smile:
Karamba,kangaroo,weaver bird,ameba, a third party component which we our self have written that, millipede , parakeet and two or three others which I don’t remember and I can not see because my grasshopper doesn’t open with the error “csv file”

Maybe this is helpful:


As for disabling Vray, you can do by running
_pluginmanager and filter for “plugins that do not ship with Rhino” and uncheck Vray and restart rhino.