Bug? Extract mesh face

Hello, I used command extractmeshface but it does not extract any face.
I closed the program 3 time and the third time have the mesh face extracted successfully.

I would say this is kind of unstable for the this command, a bug, I never know when this bug will come again, maybe in some urgent time, then I will go crazy.

Seems to be working fine here. Please run the Rhino command _SystemInfo and post the result in a reply. If you have a mesh with which the command fails for you please share that too.

240520extractmeshface.3dm (897.6 KB)

Rhino 8 SR4 2024-2-13 (Rhino 8, 8.4.24044.15001, Git hash:master @ 5d3f86ffffae3c2ed84d21147c008b3907a40a2e)
License type: 商業版, build 2024-02-13
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 64GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-15-2024
Driver Version: 31.0.15.5161
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot11RhinoPlugin (55124e8a-aa81-4be8-8e12-9f452c473970)\2.0.0.0\KeyShot11RhinoPlugin\Rhino 7\KeyShot11RhinoPlugin.rhp “KeyShot11RhinoPlugin” 1.0.0.0
C:\Program Files\SimLab\Plugins\SimLab PDF From Rhino\SimLabPDFExporter.rhp “SimLab PDF Exporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\MeshTools.rhp “MeshTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

The face extraction worked on this model for me

You’re apparently still on Rhino 8.4, I’d update to the latest service release 8.7

This is company computer and I do not know where to do upgrade. Thanks

If it is controlled by your IT departement you’ll have to contact them.

1 Like

Hello again, IT buddy ask me to do upgrade by myself. However here comes a silly question: I click help=>check for updates and the following showed up.


There is everything in gray and unable to click and do anything. What should I do? Thank you.

“close Rhino to install the new version”… I tried closing the Rhino and no install started. I see" Downloaded: rhino_en_us8.5.24072.13001.exe" in this screen… but where is it located?

Just close Rhino - the closing process will ask you to install the update it has downloaded. You can also just press the Check Now… link to the right of the dialog just below Service Release dropdown.

I cannot click anything- look like it is disabled, they are in gray color.
It didn’t start upgrade after closing Rhino, nothing started.

Ah yes, I missed that the section is disabled. Not sure why you wouldnt be able to check the box in the topleft. @pascal @wim @Gijs any idea?

@VinPo if you run TaskManager, do you have McNeel Update service running?
If that doesn’t make a difference, the next thing I’d try is a repair of Rhino.

Hello, I have tried repair but nothing change, upgrade is still disabled…

These are downloaded to one of the subfolders in

%userprofile%\Appdata\local\McNeel\McNeelUpdate\DownloadCache\

-wim


I just found these in McNeel folder. Can I use them to do manual update, and how?

No, those are not the files. Copy and paste the following line to he address bar in the window you just showed:

%LOCALAPPDATA%\McNeel\McNeelUpdate\DownloadCache

It will contain the file that was downloaded.

If that fails just go to Rhino - Downloads and download the latest Rhino 8 installer manually.

I manually updraded the Rhino to R8.7. Thank you.
I guess the McNeel disabled the automatic update, so everything is in gray color and cannot click anything.

It might be that your Rhino version was installed with updates disabled, possibly even internet access disabled. Check Automating installation Rhino 8 for Windows: Scripted Install [McNeel Wiki] - rerun the installer from the command-line with ENABLE_AUTOMATIC_UPDATES=1 DISABLE_INTERNET_ACCESS=1