ExtractMeshPart problem

Hi All,

I am having problems in V6 with ExtractMeshPart command. Many times a selected face/part would just blink and get deselected instantly instead of being included in the selection. This is V6 only, in V5 all works fine.
Here is a sample model, where the sides don’t work. Wondering if anyone else can see this:

ExtractMeshPart_sample.3dm (59.1 KB)

–jarek

Hi Jarek - that works here in the build of the day…

image

-Pascal

Hi Pascal,
Now I see the file I copied it to works OK too, maybe it has to do with units/tolerances? The original one is in MM and most meshes don’t work (some of their faces).
How about this one (big face) ?
ExtractMeshPart_sample.3dm (68.6 KB)

Here’s what I see:

Ok, I think it is something weird with the meshes that I have imported. After running _RebuildMesh on all of them, add ExtractMeshPart faces work OK. I would say it is solved then, not sure where these meshes are coming from, but they were not created in Rhino.

Hi @Pascal,

I think ExtractMeshPart does not work with NGon meshes… that what the imported ones came in as.
_RebuildMesh converts the NGons to triangles, that’s why the command works. It would be nice if this could be tweaked to work with NGons, now that we have them in V6.

thanks,

–jarek

Hi Jarek - I see that, thanks.

https://mcneel.myjetbrains.com/youtrack/issue/RH-48836

-Pascal

great, thanks

Hi @Pascal,

sorry, there seems to be another problem in ExtractMeshPart.

There are issues when trying to extract parts from several separate meshes in one go. In V5 all worked OK, Now try this:

  • Make 2-3 MeshBoxes.
  • Run ExtractMeshPart, and try picking several faces of seveal boxes. The selections start randomly switching on and off making it impossible to select a desirable set : /

If the boxes are joined into one mesh, all runs fine.

Thanks @Jarek, I can repeat and have reported it: https://mcneel.myjetbrains.com/youtrack/issue/RH-48829.

-David

1 Like