Brep|Plane intersection fail

forum missed (59.6 KB)

Is this a bug?

I think you must use PlaneSurface and make it big enough.

For some Reason planes have size in Rhino. It makes no sense. Probably because there is no real plane object in the api, only planar objects.

I would think so, yes. Regular Rhino doesn’t find the intersections with your Brep object either. I’ll get that on the list.

Reported as RH-49219

The problem comes from the poor parameterization of the surface in the brep where the intersection fails. Can you tell me how it was created?

A colleague handed it over to me. I ran explode, rebuildedges, shrinktrimmedsurface, and join commands on it and the intersection worked. Just the typical carelessly created brep…

The face was a loft between two curves, one of which may be a 3d curve.

Thanks for the information. So far, I can’t recreate the bad parameterization using loft, but I’ll keep looking. I will also see if I can work around the badness and get intersect to work anyway. EDIT: If you use the Loose option on loft the parameterization is bad. I’ll fix that. RH-49231

I know my colleague created the loft in grasshopper. Isn’t normal the default option? I don’t think he input a user option.

I’m not familiar with the workings of Loft in Grasshopper. Maybe @DavidRutten has an idea. The low level loft code for Normal gives the correct parameterization. I’d assume Grasshopper is using that. Loose was giving the bad parameterization, and that is now fixed.