Boolean fails for multiple intersecting circles


#1

Hi Everyone! :slight_smile:

I am new to this forum and to CAD.
I wonder if anyone can help me with this issue.
I have created all the intersecting circles of the flower of life
symbol and added a dynamic profile to the curves. It seemed to be the
best solution as extruding the curves didn’t do the job.
The final result looks great, however, I couldn’t
join all the pieces together with the boolean union as it seems to have
too many intersecting spots.
Is there a way to do this that I am not aware of?
I am using rhinogold, but I know that a rhino way to do it will work :slight_smile:
Thank you sooo much for your help in advance!
xo,

Marci


(Brian James) #2

Can you post a file or screenshot showing your model? At a guess, you might be able to use CurveBoolean on all the overlapping curves if they are coplanar before extruding. To troubleshoot why a Boolean isn’t working I’d need to see the file though.


#3

Thanks for replying Brian :slight_smile:
I am attching a test version of the file!
I thought of curveBoolean and tried, but maybe I didn’t do it right :slight_smile:


#4

Not sure the file was uploaded, I am attaching a screenshot…
Thank you again!!! :slight_smile:


#5

Here are the initial curves I used for the profiles created… :slight_smile: Cannot seem to get the final surfaces to join.

:slight_smile:


(Brian James) #6

Thanks for the screenshots Marci. I bet the 3dm file is too large for posting on the forum. You can use www.rhino3d.com/upload though and put this conversation link in the notes. It would be good to have the file for a bug report.

The issue appears to be the coincident singularities at the ends of the individual sweeps. One possible solution is to use Mesh on all the surfaces and then try a MeshBooleanUnion which can be more forgiving. If you are printing the part for casting you’ll need a mesh anyhow so this may be fine. Some other possible fixes are to move some of the sweeps slightly up or down to lesson the coincident intersections at the ends. You can also try Booleaning only a few at a time and then work your way around to include them all, sometimes this can help too.


#7

Hi Brian,
Thank you again for your help! :slight_smile:
Unfortunately neither of those options worked. I tried the mesh boolean, and it gives me some weird results with parts disappearing, tried repairing mesh, tried booleaning a couple pieces at time, this worked a few times specially if the pieces were split, but then it just doesn’t go any further.I will have to find another solution. Thank you anyway!
Have a great weekend!

Marci