Bongo menus not loading properly

As indicated earlier, after installing R6 some Bongo toolbars doesn’t load properly (I find only the Bongo Main . I don’t know if the two problems shown on the command line is related, but this is what is reported on startup:


I have no idea what “Root element” means in this context.

My toolbar folder looks like this:

There’s also no “Bongo group” of toolbars left in my Rhino5 menus after installing R6, only the following toolbar resides alone in the list

Having both R5 and R6 on the same machine.

// Rolf


Would you be able to send me those rui files?

Also just checking - is the problem only in Rhino 5?
What version of Rhino 5 (and Rhino 6 if the problem is there also) do you have installed?

Absolutely yes. Rhino 5.14 (latest) and R6.2 (updated yesterday). This means that it’s possible that the latest R6.2 wouldn’t have caused this, since it already happened before the update.

Anyway, I zipped also the bak-versions if there’s any traces left of how this happened (probably no traces left, but anayway): (387.7 KB)

In Rhino 6 the tabs are in place, since the menus can be loaded normally. R6:


But in Rhino 5 I can’t even explicitly load (or “open”) the rui’s even if I pick the file via the dialog. R5:

// Rolf

Something is clearly wrong with the v5 toolbar file you sent.
I get the same error, also file size is only 1KB, it should be over 100kb.

We’ll take a look.

1 Like

Hi Marika,

I have the same issue after installing SR6 in Rhino 5. Bongo toolbar is missing and cannot be loaded. Is there a fix to this?

Plus, same error of “root element is missing”. I uninstalled and reinstalled SR5 version and still the same issue…

Please try the following:

  1. Go to: C:\Program Files\Bongo 2.0 (64-bit)\Support and copy the file called Bongo.20.v50.rui
  2. Go to C:\Users\Your user name here\AppData\Roaming\McNeel\Bongo\2.0\
  3. Rename the Bongo.20.v50.rui -file in that folder
  4. Paste in the Bongo.20.v50.rui -file you copied in step 1.

Does it work any better now?

Hi Marika, I ended up uninstalling (and clearing out all folders), reinstalled and it works fine…

It worked for me. Thanks.

// Rolf