Bolean union FAİL (but there is no naked edges)

Hi there eveyone,

For the last 3 days I am having a trouble in Rhino. I have a solid terrain and hundreds of solid buildings. I have to union terrain with all buildings.

When I try to d it in rhino it fails, I have also tried grasshopper but it didn’t solved problem either. I created loops to do it one by one since I thought that the problem courses when I try it with multiple breps but it didn’t solved problem either. I scaled randomly and moved randomly buildings in grasshopper to avoid any overlapping edges but no…

I am really about to lose my mind :slight_smile:

If anybody knows the problem and the solution I’ll be really grateful
You all have a nice day !
SS 2021-04-04 181709|690x374

Hi @nuriseckin9,

I think you will find you have a smattering of issues with the buildings.

For example, where three buildings come together at an angle with a common edge like this:
Rhino sees it as non-manifold when it tries to merge them and doesn’t like it.
However, if you merge just a & b, you can then merge them with c.

Another example is a building where one of the edges has folded back leaving two coincident back to back faces:

This needs to be exploded and rebuilt without the extra faces.

As a strategy, I would focus on the buildings and try running union on a subset of of the groups of them at a time. If the union(s) succeed, move the results to a temporary layer in a different colour so you can track what you have done. If the union fails, work through the groups until you find the problem, moving successes as you go. Work out what caused the failure and fix it then carry on. Once all the building unions succeed union them to the terrain.


Hi @jeremy5 ,

Thanks for your time. Doing this manually doesn’t sound good :confused:. When I have some time maybe I’ll try to do the method you explained in grasshopper. Have a nice day :+1:.