Block display slowness bug in Rhino 5


#1

I have a file with a forest with 1000 trees and needless to say it slows down Rhino a bit. So when I need the speed I turn the layer off. But then I realized that if I only turn off the layer that the block parts are on, and not the layer that the blocks them self are on, then things doesn’t speed up. Even though the scene appears empty and there is nothing to select.
(They layer with the blocks are on and the layer whit the block parts is off.)

So apparently Rhino calculates where all those parts are even though it “knows” that they are not visible. I imagine handling the “what parts are visible” prior to handling the blocks would speed up Rhino quite a bit regarding blocks in V6.

I’ll send a file if you need to check it out your self.


(Steve Baer) #2

Yes, please send me a file


#3

Hi Steve,
sorry for the delay, one thing took the other and suddenly 9 days has gone by.
Here’s the simplified version of the file.

I made a block called tree with two meshes. They are on the Tree layer.
The tree blocks are all on the Forest layer.

Manipulate the view and notice the speed
(just for later comparison, this is not a rant about the actual speed, even though I would love to see this improved)
Turn off the Tree layer and see that the file is still slow to manipulate, like if Rhino still handles all the data.
Now turn off the Forest layer and manipulate to see the full speed.

Thanks for looking into it. Blocks needs all the love they can get.

Slow hidden block parts.3dm (3.0 MB)


(Steve Baer) #4

Thanks; I’ve logged this bug at https://mcneel.myjetbrains.com/youtrack/issue/RH-36261


(Brian Gillespie) #5

RH-36261 is fixed in the latest WIP