BlendSrf Failure (sometimes)

Hello all,

I’m getting inconsistent results with BlendSrf on two very similar, very simple surfaces. Both surfaces were swept using identical rails and cross sections. Both surfaces had an extra edge split (6:00, mid-snap on bottom edge of open srf) to make it possible to blend one side of the polysrf to the other. One blend works, one doesn’t.

What is the difference? Why does one work and the other not?


BlendSrf.3dm (201.3 KB)

dear @MikeM
i can not answer your question about the difference between the two trails.
in general _blendSrf likes edges best, that chain with G2 or at least G1.

I think the the basic intention of _blendsrf is not to blend edges that have kinks.
But maybe someone might disagree on this.

i would recommend to do two gos of _blendsrf, one for the top part (which also can be a _planarSrf, green) and one for the lower part. (red)

if you have this kind of geometry - also a _revolve might give a nice design - but of course another intention.

this kind of geometry also might look like this - no need to build a planar Surface with _blendSrf

the workflow:
_filletCorners R0.2
_splitEdge (MidPoint)
_plane 3Point

hope that helps - kind regards -tom

Hi @Tom_P,

Thank you for the reply and for the alternate workflows. I actually tried the side-to-side blend that you recommend, and oddly I get a very different result on the blend. I’m guessing that whatever is causing this is also causing my original blendsrf (with chain edges) to fail as well.

Any thoughts (from Tom or anyone else) on why this blend would fold at the bottom? Again, it only does this on one surface while the other surface blends as expected.


Hi Mike - I’ll look at the blend part, and report back, but to make this shape more simply, I think I would start from the desired planar shape, extrude, and fillet the edges.

In see the blend failure…


Hi @pascal,

Thanks for taking a look at it. I’m trying to do more than create just this one shape, it’s more about creating a stable, repeatable workflow.

For more context, this blended cap is one end of a longer polysurf that needs to cut around gems, so the cross-section of the polysurface is important. The length of the polysurface is dependent on the # of gems in the row, which will vary. It’s also important to be able to adjust the length of the blended cap to make space for the gems, so a revolved end won’t do the trick either.

I’ve used BlendSrf for functions like this for years and had good success with it, but it will occasionally fail especially when the surface is too bent to blend well. That’s part of why I’m setting this up to blend on the flat version then Flow it onto the ring. I thought I would get more consistent results. This is the first time I can remember seeing it fail on such a straightforward geometry.

turn on checkbox “interior shapes” … you should get a result… but still there might be some strange stuff with the edges, that are to dense… see pascals approach as well

Thanks for that, @Tom_P . :+1: Turning on “Interior shapes” fixes it as long as I’m only blending the sides together. Still nothing if I use chain edges to blend the sides and top at the same time.

Hi Mike - I get that the blend failing is wrong, and we’ll look at that but I am not convinced, yet, about why you need this workflow if you are going to Flow the part. But working with that for the moment, the surfaces are very overdefined, to my eye -

In addition, the corner curves are g1 - if you have arc-shaped curves there and they are G1, that suggests a fillet may be a better bet - perhaps even on the square-section piece after it is flowed. i.e. even if it works sometimes, I am not a fan of the workflow… But I will ask a developer to look at the blend failure.
RH-65937 BlendSrf fails



Thanks! It just seemed so odd that the BlendSrf would work on one polysurface but not the other when they are essentially identical.

if i rebuild those 2 top stripes (retrim) same amount of points, same degree _blendSrf works as you expected - on go for the cap.

also only (on those two planar stripes
will make it work.