Blend Surface Problem

I can’t blend a surface between the two curves because it shows that the curve is not a complete curve.(like the below pic)

however, when i click it without blending it, it appears to be a closed curve.

please help.
1026.3dm (142.7 KB)

Dear User12 - it s always nicer to talk to a real person s name ?
you are talking about
_blendSrf ?
and you use it with position continuity ?

you can drag start end endpoint of _blendSrf to only use a section of an edge. this might be a bit tricky.

it might be easier to use
to modify the segmentation of the edge (as long as there is G1 / tangent continuity )
does this help ? - kind regards -tom

1 Like

To add to @Tom_P’s advice, there’s also the ChainEdges option in BlendSrf to help you.


I would simply extrude the original curve profile that was used to split the cylinders, then split it by the latter. As simple as that. :slight_smile:

1 Like

Hi, I Merged the edges and they appear to be a complete curve.
However, when i want to click the edge to blend a surface, i can only select half of the curve.
I can only do it separately. First a half then the other.


after _mergeEdge i can (sub-) select like this:
sub-select = cltr shift left klick (pc) or cmd+shift + left click (mac)

_blendSrf inital

the inital BlendSrf looks like this

_blendSrf add shapes

then you have to add shapes to match corresponding edges (end-snap, perpendicular snap)


i think Bobi s workflow is also nice - did you try it ?
if you need a surface that is perpendicular to the outer surface - there is _fin command.

kind regards -tom


yes i did tried Bobi’s workflow.
Thank you for your detailed reply, Tom.