Best settings for Rhino Performance Required

I’m new to Rhino and just need some tips for speeding it up as it’s struggling on a new work machine. General workflow includes.

Importing point cloud data,
Importing other Rhino files

I’ve tried to open a Rhino file from a 3rd party that was 171mb, however it struggled and failed to open. I’ve instead imported the model, however navigating around it is sluggish and painful. Are there some settings I can adjust to optimise the general performance?

What I have in the current HP laptop:

  • Intel Core i7-8665U CPU @ 1.90GHz 2.11 GHz
  • 32.0GB Ram (Unknown)
  • AMD Radeon Pro WX3200 Graphics
  • Intel UHD Graphics 620

I’ve seen a lot of references to an NVIDIA graphics card, however this is a work laptop and is what I’ve been given. Rendering is not as important to me as coordination and navigation, so if I have to give up some of the Jazz to get the keep the party moving then that’s preferable.


Hi Rob - could you please run the Rhino SystemInfo command and copy-paste the result here?

I would look into using custom display mesh settings. For some models the defaults are not great.

Rhino 6 SR27 2020-6-24 (Rhino 6, 6.27.20176.05001, Git hash:master @ ba2c30de00be5a8b210bc297715204e941911799)
License type: Evaluation, build 2020-06-24
License details: Cloud Zoo. In use by: Rob James ()
Expires on: 2020-10-19

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: PTY101

Hybrid graphics system.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 5-5-2020 (M-D-Y).
Primary OpenGL: AMD Radeon Pro WX3200 Graphics (AMD) Memory: 4GB, Driver date: 2-4-2020 (M-D-Y). OpenGL Ver: 4.6.13587 Compatibility Profile Context FireGL 26.20.14001.50001

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 2-4-2020
Driver Version: 26.20.14001.50001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Veesus Arena4D For Rhino 6\Arena4D.rhp “Arena4D” 2.6.7506.22162
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thanks Wim / Scott

I’m currently running a trial on this laptop as we are currently in the process of purchasing. Tried the models on a colleagues laptop that wasn’t as high spec and his opened the file like lightening. I’m thinking there maybe some issues with the configuration of the laptop too possibly.

Hi Rob - did you also try running Rhino without the Arena4D plug-in?

Hi Wim

Just disabled the plugin and it seems to be working fine. It open the file it was struggling to open before pretty quickly. Although it now poses me with another problem of workflow with Arena 4D, as we have some point cloud files I am hoping to use as the basis for our design and coordination.