Need help for fast working settings for rhino

Hello,
I am a very starter for rhino so the question might sounds a bit stupid.
But anyway, I have sent few days on modeling complex machine-like building with lot of details
and now rhino is wayyy too slow for me too work… it would literally freeze when I turn the view even I just bought a really nice customized computer to work on.
How can I run rhino faster? Which settings should I change and turn off?
I heard something about meshes. If I change the mesh setting, is it possible to turn back to good quality setting and how?

Thank you so much for reading this.
Regards, Pete

Hi Pete - info on display mesh settings here:

https://wiki.mcneel.com/rhino/meshfaq

But it sounds like there is maybe more to it than that - can you please run the SystemInfo command (Help menu > System information, and copy/paste the output here?

-Pascal

1 Like

Hi,
Pascal
Thank you for your reply.
My setting was already on ‘Jagged and faster’
Although I’ve tried to look for systeminfo, since my rhino is vers. 5, I can’t
look for the output.
Is there any other way to send you the output?

Regards,Pete

You can take a screenshot of the OpenGL settings:
Rhino Options > View > OpenGL - like this:

Also, let us know exactly which Service Release of RH5 you are using.

1 Like

Hi Pete,
The .3dm file you’ve posted was created with a cracked copy of Rhino 5.

Before you post on our forums again, please make sure you are using a legal copy of Rhino. If you do not own a legal copy of Rhino, you can purchase one from here:
https://www.rhino3d.com/sales/

You will find that Rhino 6 handles large models a lot better.
wim

1 Like

Dear forum goers,

I am currently learning Rhino + Grasshopper and even a simple geometry like the one here is hanging while orbiting. Not sure what can be done here?

Specs below.

Does anyone know what might be going on here? Is my desktop just not powerful enough for Rhino? Completely new here so please forgive me if I accidentally opened up an old thread and am not supposed to.

Hi and welcome -

It’s a bit underspec’ed for running Rhino 6.
From the system requirements:

  • OpenGL 4.1 capable video card is recommended.
  • 4 GB Video RAM recommended.

That said, it looks like there is an updated driver available for your GPU:

You might want to try that.
-wim

1 Like

Thank you, Wim. I really appreciate your response. I just updated the driver and will look into the 4GB video RAM and see if there is anything I can do on that front. Hope you have a great day! Thank you.