Avoid or fix oscillating/curvy isolines when lofting?


#1

Hi there,

I have several closed horizontal curves (cross sections of a body) from which I want to create the corresponding polysurface. Each curve has (the same number of) points at equidistant angular steps, which means that the points of the same angle connect to a straight curve:

Using the Loft-command I can create a polysurface, but the vertical isolines tend to oscillate and get very curvy, which makes the next steps of processing complicated.

I need them to be as close as possible to the original lines of constant angle, while still creating a single continuous polysurface (and not an assembly of surfaces between vertical lines). Is there a setting to avoid these curvatures when lofting or - alternatively - to somehow straighten the isolines up afterwards?

Thank you very much!


#2

In theory, if all the curves have the same degree and the same number of points, they should connect logically… However, as your curves appear to be polylines and the surface you’re making is not faceted, you have some other settings in loft options (like rebuild) that seem to be causing it to not follow the existing point structure. Can you post the curves and settings?

–Mitch


#3

Thanks for your reply.

In the images above there really is a rebuilding going on. Without the rebuilding, the edges really are straight, but then the surface of the object is essentially composed of multiple joined surfaces instead of one continuous surface (which I need).

And you are right, that the lines in the example above are polylines and not curves. However, even with curves as the input and no rebuilding there is some local curvature in the isolines and additionally an unpleasantly varying isocurve density (dark areas):

That was why I tried it with polylines instead of curves. I’ll try to post the curves, but since the above examples are generated by a small subset of actually many more curves (which I then deleted in rhino) I’ll have to extract some relevant curves first from the text file.


#4

Well, I suspect it’s because Rhino doesn’t know how to determine “straight” in this case… If you line up the seams “vertically”, that will be the one “straight” point. From there all the section curves are divided into an equal number of theoretical segments and the loft isocurves pass through the corresponding segments in each section. You can imagine that according to configuration of each section curve, the lengths of each segment may differ, thus the isocurves will not stay “straight” (vertical) all the way around the object.

Since there is no option in Loft similar to “Add Slash” in Sweep 2, the only workaround I could propose would be to run some vertical interpolated curves through the sections and try with NetworkSrf…

–Mitch


#5

It worked! :smile:

NetworkSrf with some vertical curves did the trick, thank you very much!
Alternatively it also seems to work when I extract the vertical contours from horizontal cross sections and loft them.

Thanks again!