Problem with lofting


#1

When I use loft with several sections of an object, I get this result. What can be the reason? I modify the curve seams, but I don’t know very well what I am doing. Any advice?


Thanks in advance.


(Menno Deij - van Rijswijk) #2

If you post the file (if possible) that could help in pinpointing the problem.

It could be a render mesh issue - if you switch to wireframe, are the surface iso-lines also looking strange? Or, if you increase the render mesh number of mesh faces, does the problem go away?


#3

Yes, they look strange. Here comes the file.
Problem.3dm (27.3 KB)
Thanks for your help.


(Menno Deij - van Rijswijk) #4

In my case I think I can loft them OK. When lofting it is important to select the curves at the same “relative” position, otherwise the lofting procedure can get confused. This may have happened in your case.

Another option would be to split the lofting curves at the deck and keel (where they have a sharp corner) and create three lofted surfaces: one on starboard, one on portside and one on the deck.


#5

I solved it but I will try what you say. In my case the problem was the different number of control points in every curve. Thanks for your help.


#6

A good process for lofting is to create one curve, then copy and move it as many times as you need. Make changes to the copies; that will ensure that you have the same number of control points AND they are aligned nicely.


#7

That’s exactly how I solved it. Thanks :slight_smile:


#8

To create a beter loft you should use less mastercurves.
This tutorial is very helpful : http://www.rhinocentre.nl/pdf_bestanden/Rapid%20Hull%20Modeling%20in%20Rhinoceros.pdf


#9

The less the better, that’s true. I am a newbie with Rhino. I know how to build curves from hull lines, but I will begin to study how to build the mastercurves in the tutorial that you have pointed out.

Thank you for your help.