Automatic zoom out when inserting a block


#1

Is there a way to avoid Rhino zooming extents when inserting a block? I’ve always found irritating trying to insert a block in a conveniently zoomed area only to be zoomed out unnecessarily to the extents of the scene … Is this by design?
Using Rhino 5


(Pascal Golay) #2

Hello - I do not see this on Insert… is the block linked? What format?

-Pascal


#3

It seems to happen only when I insert an Autocad dwg for the first time (that I’m aware of, there might be other formats that also behave like this), not with Rhino files.
If I’m zoomed in, it will zoom to extents when inserting the dwg the first time being read from disk. Once the dwg is in the list of blocks, I can insert it again normally and it won’t zoom out.

See attached video,


(Pascal Golay) #4

Hi Juan - I thought it might be dwg - when you Import one of these, there is a zoom, but I tried Insert and did not get the zoom, in V5. But that is built in to the DWG importing I guess, it is not part of the Block stuff. Still, it did not happen here…

-Pascal


#5

Strange. I thought that it could be related to the dwg depending on how it was saved but I tried with a simple dwg (a circle with origin at the center) and when I insert it still zooms out …


#6

Please try inserting the light dwg into the test.3dm model

LIGHT_PLAN.dwg (60.3 KB)
Test.3dm (69.0 KB)

By the way it seems to happen also in Rhino 6


(Pascal Golay) #7

Yep, I get the zoom with these files- I think that is expected, given the way that dwg works but the way it works may be wrong - it’s the only import plug-in that does this, I think.

-Pascal


#8

Thanks. Not much we can do I guess … :frowning:


(Pascal Golay) #9

Well, the dwg behavior is unique, I think… maybe it should be changed… I am asking around.

-Pascal