Autocad LT template import bugs

I am experiencing some bugs when opening my existing autocad lt DWG’s. They contain a model space and several paper space layout tabs. When they are first opened I have to maximize and then shrink the Rhino window them do display. Other wise when I click on them they are just all solid black. In rhino options I have unchecked enable model space scaling and enable layout space scaling. This has correct most of the label size issues but not all are carried over from the autocad file. Is there a way to bring in the autocad file just how it looked in LT? Every time I open rhino I have to reset all my settings for display ports and views can I set a default I have not seen anycheck boxes to do so. All I want is a single view port opened in top down view by default.

Computer Specs:
Windows 10 64 bit
I7 4790k
32gb ram
Nvidia GTX 1060 3gb

Rhino should not be considered a replacement for AutoCAD.
There will always be differences when importing files from another application.

That said, the symptoms you describe do not generally fit those expected differences.

Please upload a simple example file that illustrates these issues.


I am inclined to support Chirs’ opinion.

Rhino is far from being a good AutoCAD replacement @John_Brock.

@chris4, unless you need to import the drawing to create 3d model out of it, I suggest you use some of the freeware AutoCAD alternatives.

Adding this as a separate post, so the moderators can delete it if I’m violating any rules:

I suggest you try the free autocad replacement from Dassault Systemes called DraftSight. You can use it for commercial projects as well.

Rhino was never intended to be a replacement for AutoCAD.
AutoCAD is for creating production drafting documents and is still very good for that.
Rhino is intended to create accurate models for manufacturing. Drafting is a side use and was never what Rhino was intended for.
Over the years, we have added to the drafting tools in Rhino to make it more useful to a wider audience. That should not be seen as redirecting the main purpose of the application.

I am very aware of that, and Rhino is not the only 3D modeling tool that has problems with 2D drawings.

Perhaps a new 3rd party plugin dedicated for that could continue your work.

However, to get to that there must be an improvement on imports/export to correctly map not only linetypes and layers but also configurations.

Hi Chris,
A custom template should help. These issues are the same for 2D and 3D. You want to start Rhino and have the defaults be already set.

This is because when you open an DWG it is equivalent to an Import. If in the default template, Layout scale is on, then annotation that are created 12" high on the model are 12" high on the layout, sp witha sheet that is 24’ high, the text will “eclipse” most of the model. When you uncheck “use layout scale” then the test is 12" high is scaled by the scale factor of the detail…in other words, it looks appropriate. We can have you make a default template that has “layout scale” off, and that would solve this issue.

Again, the viewport layout is determined by the Rhino template. We can make a make a customer Rhino template with the top viewport maximize.
It sounds like that is what you are looking for when you open Rhino.

And set this as the default in the New command so it will be use when you start a new file or import.

Please attach or email your AutoCAD template so I may confirm my reply.

Mary Ann Fugier
McNeel Technical Support
Seattle, WA