Applying texture jpg to imported mesh V7 method is this ok?

Whilst my notes worked for V5, all is changed in V7
I have done this, is this correct, it sort of did it for me in fact !

File>import and browse to the obj file. (which was exported along with .jpg selected for texture)
it imports, go to toothpaste icon tab, alter ‘by layer’ (or whatever it said) to, and this is where it differs, I had ‘by object’ now there is an object name there but thats a red herring, select instead the long name of the obj.
then instead of having to select colour and browse to the jpg, it appears by magic !

accept this.

is this correct ?

I then in shaded mode went setObjectDisplayMode and chose rendered and I have my textured object with grid and able to model on it etc in normal shaded mode. I am confident that bit is ok, but are the prior steps ok ?



That sounds fine but there are several ways to assign a material to an object. I believe you used the paint tube icon in the Properties panel which is setting the material for that selection. Alternately, you could use the Materials panel (also the paint tube icon but not in Properties) and drag and drop a material to an object or right click the material swatch to assign that material to a present selection.

With that said, if an imported obj includes a material assignment and any texture maps are in the folder where it was imported from, the texture ought to display automatically in Rendered mode. If you want Rendered mode for only some objects, using the SetObjectDisplayMode command is the way as you know.

I hope that helps.

Hi, thats what it did, the .jpg was in the obj export and in the folder with the obj, so unlike V5 where one had to browse for it, V7 auto allocated it.

This way users wouldnt be left thinking thats a bit less crisp than the model in the photogrammetry prog, as Thino did allocate a texture but not the hi res one, which used to need manually allocating in the paint tube icon tab under colour.

Thanks for the alternatives.