Ambrosinus toolkit

@MURALI_MANOJ1 Thanks for your feedback can you share with me the file + baseimg, please?
(the image above has a too-low resolution).
Thank you :slight_smile:

Hi,
Now it runs without error but images are not saved in the path. I am not sure where it is even saved

Mmh interesting if you have some clues or settings, let me know so I can investigate :+1::blush: and make it more efficient, Right now I am testing it. I will update this post soon

OK, Seems the problem was in the management of the INFO text (I remember that in one of the late A1111 updates, they added a different text layout and the “API process” fails - I fixed that)

Anyway, below is just the proof of concept :wink: and soon I release this fix in v1.2.4 :+1: (below always CN v1.0):

Finally and unfortunately the CN v1.1.X isn’t API well-supported yet!

What is this error that keeps appearing everytime i try to render from Rhino’s viewport

And keeps getting these random renders here.

If anyone can help me here, thanks alot.

Hi and thank you for your enquiry.

It is quite difficult to predict the cause without enough info (especially because Stable Diffusion has received lots of updates recently) anyway let me start with this:

What controlNet version did you install? it seems the CN v1.0, anyway please, see below:

1) Have you installed the ControlNet checkpoint models? please, have a look below, this is my folder content for ControlNet v1.1.313 (path: SDlocalCNv11\stable-diffusion-webui\extensions\sd-webui-controlnet\models)




Here is where to download the models: lllyasviel/ControlNet-v1-1 at main
Evaluate the possibility of using this version.


2) this one is for CN v1.0 (path: SDlocalCNv10\stable-diffusion-webui\extensions\webui-controlnet-v1-archived\models)



Here is where to download the old models (only for CN v.1.0): lllyasviel/ControlNet at main
Check here for extra info: GitHub - lllyasviel/webui-controlnet-v1-archived: WebUI extension for ControlNet (v1 archived)

1 Like

I noticed that some clusters especially the Meshy components when run into Rhino v8 can generate the error below:

E:\Automatic 1111\webui>webui-user.bat
Already up to date.
Couldn't launch python

exit code: 1

stderr:
Python path configuration:
   PYTHONHOME = '\\?\C:\Users\iamsa\.rhinocode\py39-rh8'
   PYTHONPATH = (not set)
   program name = 'python'
   isolated = 0
   environment = 1
   user site = 1
   import site = 1
   sys._base_executable =
'C:\\Users\\iamsa\\AppData\\Local\\Programs\\Python\\Python310\\python.exe'
   sys.base_prefix = '\\\\?\\C:\\Users\\iamsa\\.rhinocode\\py39-rh8'
   sys.base_exec_prefix = '\\\\?\\C:\\Users\\iamsa\\.rhinocode\\py39-rh8'
   sys.platlibdir = 'lib'
   sys.executable =
'C:\\Users\\iamsa\\AppData\\Local\\Programs\\Python\\Python310\\python.exe'
   sys.prefix = '\\\\?\\C:\\Users\\iamsa\\.rhinocode\\py39-rh8'
   sys.exec_prefix = '\\\\?\\C:\\Users\\iamsa\\.rhinocode\\py39-rh8'
   sys.path = [
'C:\\Users\\iamsa\\AppData\\Local\\Programs\\Python\\Python310\\python310.zip',
     '\\\\?\\C:\\Users\\iamsa\\.rhinocode\\py39-rh8\\DLLs',
     '\\\\?\\C:\\Users\\iamsa\\.rhinocode\\py39-rh8\\lib',
'C:\\Users\\iamsa\\AppData\\Local\\Programs\\Python\\Python310',
   ]
Fatal Python error: init_fs_encoding: failed to get the Python codec of
the filesystem encoding
Python runtime state: core initialized
ImportError: bad magic number in 'encodings': b'a\r\r\n'

Current thread 0x000037cc (most recent call first):
   <no Python frame>

Launch unsuccessful. Exiting.

This kind of error depends on the RhinoCode component when it runs in Python v3 (v3.9.X) mode. Anyway, I am updating these components using IronPython (v2.X) configuration and now seems that they work fine.
Please, let me know if you have encountered this kind of issue, especially what component you have tried running. In this way, I will upload the new build for these components only to run them on Rhino v8, because the RhinoCode module is missing in Rhino v7 which still works like a charm with the old Python and C# version.

Thank you in advance :wink:

[UPDATE FOR Meshy]
Demo files and ghuser objects here

Hi All - I’m only beginning to get into this new plugin (thanks @Ambrosinus for this amazing work!) and am getting a simple error from the Dall-E component:

“1. Solution exception:The remote server returned an error: (400) Bad Request.”

I’m guessing the component isn’t properly connecting online to Dall-E/OpenAI. Could it be that I’m providing an API key from OpenAI rather than Dall-E directly? I don’t see a way to access Dall-E independently anymore, as it seems to be fully integrated within ChatGPT. Has anyone else had similar difficulties with this?

Thanks for any insight.
Alex

@Ambrosinus has there been any further development in getting the SD components to be compatible with Controlnet v1.1.x? I’ve got everything working within Grasshopper but unfortunately the components aren’t responsive to any image inputs I provide. Just curious if you’ve been able to get v1.1’s API to work with this plugin. Thanks very much for the work you’re doing with this tool, very impressive!

Hello and thank you for the feedback.

it seems that Automatic1111 has updated some API features. I must investigate this for the component written in C# ("DalleFromGH), but the component developed in Python (the advanced one) still works. Remember that the advanced version needs an earlier installation of some Python libraries.

Please let me know how you feel about using this version instead of the more limited light version.

Actually, Is it possible to use the CN v1.X so that’s what there’s the “Mode” parameter. I noticed only a couple of checkpoint models such as “mlsd” that seem to not work properly.

Generally, if you encounter some difficulties in generating the images (for instance you obtain images different from the source) it can happen due to the installation process.
Basically, I suggest having two different folders for the Automatic1111 project, one with the CN1.0 version and the other with the CN v1.X.
Here is a video about the CN installation for both versions: https://youtu.be/FjrzWuE_OPU

If you want to share with me your files I can give them a try. Anyway, Generally I suggest using also a demo file too, you can get it here: SD_ControlNET_locally (github.com)

Please, I will be happy to know about your feedback.
Thanks

Grazie mille por queste informazione @Ambrosinus ! I was able to get the secondary SD install with CNv1.0 working per your recommendations. I’m realizing now that the AIImg2Img component isn’t available yet, and that the demo on your website was a preview, so I guess I’m a bit ahead of myself in what I’d like to do. In selecting canny, for instance, I’m getting the canny preprocessor image as the output, rather than a modified version of my base image using the canny preprocessor. I will excitedly await the next version of your plugin!

Hello and happy to see this! :blush:
With version 1.2.6 you should find the AI variation component (ImgToImg) in the top toolbar. You are right I did not realize the traditional video about how to work the component, but it is already available in the AI subcategory. Here is the article

Remember that at this link on my GitHub, you can find also the gh demo file :wink: (this one : SD_Local_ControlNET_v10-11_v126_AIvariation_base&server_demo-01.gh)

Interesting - I open that definition, but am getting the empty component showing up, indicating the component isn’t available. I have the latest version of Ambrosinus Toolkit installed via the Package Manager. Is it possible to get a .ghuser file for that particular Img2Img component instead?

Hmm - I just opened the same definition in Rhino 8 and it worked there. Not sure what the issue is, but I should be good to go now. Thanks again @Ambrosinus

Hello and thank you for your feedback :blush:
Did you check the version installed on Rh 7? There is an Ambrosinus-Toolkit component (the first one with big “i”, to understand what happened… because I have installed the toolkit again to check it and everything works properly.

For instance, I see from your picture that also other components are missing…I believe that on RH 7 you have a previous version of something like that.

I suggest removing any ATk installation from your Grasshopper library (where you load the food4rhino files) and installing it again from the Rhino Package manager. below is the current toolbar (v1.2.6) with the latest components, included some clusters from GitHub page:

I will wait for your feedback, thank you for your interest in this toolkit! :wink:

I have the latest version (1.2.6) installed in both Rhino 7 and 8 - not sure what was causing the issue. But I was able to copy the component over from the Rhino 8 GH instance, and that allowed the ImgtoImg component to become included in the Ambrosinus tab, so we’re all good now. Thanks for the troubleshooting assistance!

Hello, dear Ambrosini,
Thanks a lot for your very helpful tool!
I have a problem with the result.
I have installed a new version of Automatic1111 with ControlNet 1.0
The results are way different than the screenshot taken from Rhino. And I guess it could be due to the index of the controlnet models.
How do we know the index of the models. Is there a component like the SD models info component which shows the models and the indices?


Also, a note, when working on the same installation of Automatic1111 with the same screenshot, the results are fine.

Hello, thank you for your message :blush: Right! When you use CN v1.0 from the setup launcher you have to set up the Automatic1111 folder wherein you downloaded the CN v1.0 and vice-versa when you want to use the SD with CN v1.X. This is the only way to sync Rhino+Gh with the right Stable Diffusion API.

About the right index for now the best way is in using the value list presets. They have been marked as CNv1.0_Mode and CNv1.X_Mode. Remember also to switch the param “CNvers” according to the SD version launched at the beginning. When the “black viewport from CMD command” starts, you can read the name of the Mode selected. Anyway, the ordered list of all models included is coincident with the list inside the Grasshopper value list provided with the gh demo file.

CN v1.0
image

CN v1.X

1 Like

Great, everything works well. The output is the edges, lineart, etc. And from previous comments I see that you are working on the image to image development for the next version.
Thank you a lot for you valued efforts.