.ai import scaling not working in Rhino 6

When I import certain .ai files into Rhino 6 the scale is wrong. This file should be 280mm wide but it’s 40mm:

I’ve set the import options to ‘preserve units, 1mm in AI = 1 Rhino unit’.

When I choose ‘Fit to default screen’, or any other scale, the results are exactly the same.

In Rhino 5 it works fine:

I have Rhino 6 installed on another pc, and there it imports on the correct size. However, it always seems to import with ‘preserve units’, even when i choose ‘Fit to default screen’. It seems to me that switching between the import options doesn’t work, and that rhino just remembers the first ever chosen option. How to fix this?

illustrator file.zip (117.9 KB)

So you have 2 different computers with V6 and you get different results on them? Are you running the same release of V6 on them both?

Yes, both are running Rhino 6, 6.13.19058.371

I’ve tried exporting the rhino options on the ‘working’ computer and importing them on the other, but the results are the same.