Adding huge pointclouds -> bug

Hello, it seems when merging giant point clouds sometimes in the resulting PC there are massive amounts of points missing.
This might be related to a limitation of the pointcloud object, however in this case I think a warning would be adequate…
I did a quick video:

Can someone confirm this?

Hi Andreas,

This could be a display issue as well. Can you look at the Object details of each cloud before adding, as well as the result?

1 Like

mmmh… indeed… I have a 3090 how is that possible ?

Thanks Japhy!

It’s potentially a bug, i’ll ask around a bit and get back to you.

On a side note there is the potential here to reduce the number of points, either by using cloud compare or the cockroach plugin on food4rhino on the foliage.

1 Like

yes, I am running some test with cockroach, this is probably a great program but I am missing a manual which explains the algorithms a little more specific.
Is there a simple to use approach you know of to have an “intelligent” downsampling so that areas of high density will be reduced more than low dense areas?
Would cloud compare be the better bet here?

I haven’t been able to replicate the disappearing points when adding points to a point cloud.

Can you post your SystemInfo (Rhino Command Line)

of course:

Rhino 7 SR19 2022-5-10 (Rhino 7, 7.19.22130.15001, Git hash:master @ d1ce997263f5027a4d6f62f5f4e193055e56beff)
License type: Kommerziell, build 2022-05-10
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3090 (NVidia) Memory: 24GB, Driver date: 4-20-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.59
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-20-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 24 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Doliwa Workshop\Rhino Nature\Rhino Nature.rhp “Rhino Nature”
C:\Users\walth\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.22126.1613
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\OctaneRenderForRhino (f109bd23-4cf3-4c0b-9f83-06be474b0152)\2021.1.3.131\RHI Installer 7\Rhino 7.0\x64\OctaneRenderForRhino.rhp “OctaneRenderForRhino” 2021.1.3.131
C:\ProgramData\Beam\App\RHINOBEAM.dll “MKS BEAM”
C:\Users\walth\Downloads\crayon111\Crayon1.1.1\Crayon.rhp “Crayon”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter”
C:\Users\walth\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\2.0.4-beta\Substance.Win.rhp “SubstanceImporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.19.22130.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Your video card looks pretty solid and up to date. One thing we can try is to disable any superfluous plugins that don’t ship with Rhino via File>Preferences>Plugins

Is there a simple to use approach you know of to have an “intelligent” downsampling so that areas of high density will be reduced more than low dense areas?

I don’t a good answer to your previous question offhand, i will have to do some research.