Adding depth to a mesh import

Hello, I have drawn a cartoon cow’s head using rhino5, then used RhinoCAM ART to create the 3d mesh as seen in the photo.
I would like to set this mesh onto a sign, but it needs to have 1/2" added to the back so it stands out from the sign. I have tried Right Click-Control-Drag to give it some depth, but it just crashes my system. What way can I produce a curve around the outside so I can make a solid the shape of the cow’s head 1/2" tall? I do have the original curves, but because of how RhinoCAM ART creates the Sweeps and Puffs, the actual mesh is slightly larger than the original curves.

Hi Kevin - assuming the outer edge is naked (if it has a planar back, ExtractMeshPart should pull it out):

  • DupBorder
  • Extrude this polyline down, Solid=No,
  • Mesh the result, delete the extrusion
  • Join the mesh to the sculpty mesh (edges should match up but hard to be sure without the objects) and if there’s a back mesh, join that.


Pascal, I tried your instructions, it does have a back, but when I use ExtractMeshPart it only picks one spot on the back, not the entire back. Do you have a suggestion on how to remove the entire back to make the edge?
It is a 25MB file so it does not let me upload the file to look at.
Thank you

Hi Kevin - please zip and upload to my attention here:

Meantime, try Weld on the mesh at say 30 degrees and see if ExtractMeshPart on the back works.

@Kevin_Johnson - yep that works - Weld the mesh, ExtractMeshPart, Move the planar back meshes .5 " DupBorder and extrude the result (Note: two curves!) Mesh these with Refine unchecked in the Mesh dialog (Detailed controls) and Join, four meshes all together.

To make sure, use UnifyMeshNormals on the result, then Check for validity and ShowEdges for nakeds,


Thank you for your help Pascal

Where is a good place to learn more about Meshes, mesh settings, editing meshes?


Hi Kevin - one thing to bear in mind is that while Rhino handles meshes to an extent and has some decent repair tools (mesh menu and sub-menus) , it is not a mesh modeler and the tools for actually modeling with meshes are limited. In particular, operations that involve intersecting meshes are dodgy - MeshTrim/Split/Booleans…

Info about generating meshes from surfaces in Rhino- the settings and so on, is here:


Hi Pascal

After doing a check for validity and show naked edges, I found two “holes” between the left ear and eyelash. I used Dupborder-patch-mesh-erase patch- join 3 meshes to have a mesh with no holes. It still gives me naked edges around the mesh patches I made. This will be “good enough” for milling it out, but is there a better way to fix the problem. I should have caught the problem at the beginning when I was drawing the original curves.

I can upload the file again if you would like to see it.

Thanks Kevin

Hi Kevin - just repeat the process - DupBorder would have left a curve there - extrude it .5, mesh, delete the extrusion and Join the mesh - this assumes there is a corresponding hole in the back face and you’ll get a ‘tunnel’ through the finisted mesh. If you don’t want the hole at all, FillMeshHoles on what you have,