3dm thumbnail preview gone in Windows 7?


#1

Hi…,

I’ve got a customer call, that the 3dm-thumbnail previews are suddenly gone in Windows 7 explorer. The user uses Rhino 5 and also has tested Rhino 6 WIP.

Any ideas?

Thanks

Michael
www.flexiCAD.com


(Pascal Golay) #2

Hi Michael - all I can find so far is this from Dale Fugier:

Try this:

1.) If you are using Vista/Windows 7, launch an administrative command prompt:

http://www.howtogeek.com/howto/windows-vista/run-a-command-as-admin

If you running XP, make sure you are logged in as an administrator.

2.) From the command prompt, change to Rhino’s SYSTEM folder (e.g. C:\Program Files\Rhinoceros 5.0 WIP\System)

3.) Run the following:

regsvr32 rhinohandlers.dll

Does this help?

– Dale

-Pascal


#3

Hi Pascal,

thank you very much. I will forward your/Dales tip. We will see, what the customer says.

Have a nice day

Michael
www.flexiCAD.com


#4

Hi Pascal,

my customer has tried it, but get the attached error, and no thumbnail-previews are shown.

Any other ideas?

Thanks

Michael
www.flexiCAD.com


(Pascal Golay) #6

Hi Michael - I’m checking on it -no good ideas yet…

-Pascal


#7

Hi Pascal,

should I recommend a reinstallation of Rhino 5? Could that help?

Thanks

Michael
www.flexiCAD.com


Block previews not visible in library (Windows 10 x64)
(Pascal Golay) #8

Hi Michael - It cannot hurt - running the installer and choosing ‘Repair’ may be enough.

-Pascal


#9

Hi Pascal,

here the latest status: Repairing brought thumbnail preview back for old 3dm-files. All new generated 3dm-files (Rhino 5) still miss the preview. Hm?

Any further ideas?

Thanks

Michael
www.flexiCAD.com


(Pascal Golay) #10

Hi Michael - thanks-
@dale - do you have an idea about this?

-Pascal


(Pascal Golay) #11

Hi Michael - running DiskCleanup (Windows built-in app) to remove old thumbs:

then restarting the machine may help…
(thanks, Dale)

-Pascal


(Ufuk Bircan Özkan) #12

It may not be related to this specific issue, but users who have installed Sage Thumbs may have the same problem like me.
For the solution I selected “use embedded thumbnails first” option from Sage Thumbs settings and added 3dm file to the filetypes (I don’t know if this was needed), and now I can see all thumbnails of old and new files.


#13

Hi Pascal,

this fixed the problem.

Thank you very much to you and Dale

Michael
www.flexiCAD.com


(Pascal Golay) #14

Great, thanks for letting us know.

-Pascal