3D Connexion not working in Axial Rotation on Perspective Viewport

I have a rather odd bug with using my 3D Connexion 3D mouse in one viewport in Rhino.

If I try any rotation of the model/workspace nothing happens in spin, tilt or roll (Yaw, Pitch, or Roll in aviation speak) This is just in the Perspective viewport in Rhino 7 following the latest update end of March beginning April 2021. Zoom and Pans work fine.

I have no problems with the 3D mouse in Blender, FreeCad, Fusion360 or in the 3D Conexion Trainer app. So I’m sure it’s not a hardware issue. It was working fine a few days ago but on Thursday it stopped working for Rhino 7

Anyone else with this problem?

Any suggestions as to how it might be fixed? I’ve tried new models and old models it seems to be universal in Rhino no matter what file I load.

Unfortunately I’m pretty new to Rhino so please can you keep things to simple plain English and don’t go into heavy geek speak. My first post here.

Any help would be much appreciated.

Widows Desktop PC with 16Gb RAM and 4Gb Nvidia Graphics card Dual displays.

SOLVED :smiley:

Thank you Nathan that gave me the clue I needed to fix my locked axis problem…

OK hopefully this will help anyone else out there that falls foul to this feature of the 3DConnexion mice. Each model has this in a different location but there’s actually a lock axis feature I was oblivious to and I dare say several others will be too.

On my SpaceExplorer its actually marked up as 2D. It’s the smallest button of the 15 buttons on my device located on the short cut TOP, LEFT, RIGHT and Front buttons I know some other devices have it marked with the 3DConnexion logo some it’s also marked as an arrow around the equator of a representation of the mouse joystick and it is possibly accessed from the left mouse of the SpaceNavigator

I’m kinda pleased in one regard and yet embarrassed also to say that I now know what that little button marked 2D means

Anyways Hopefully this will resolve other people’s frustrations and help others fix their 3D Mouse. I’m so happy I’ve now got it working again.

Thank you Nathan for the clue and I’d also like to give a special mention to Paul at Simply Rhino here in the UK for being there and giving support on the end of a phone and via emails. Great service and this was exactly what I was after for support and so glad that I purchased Rhino through Simply Rhino.

Cheers guys enjoy a virtual pint with me please :smiley: :beers: