2D Lines Drawing Performance


#1

Hi, Running Rhino 5 64bit SR 11 on

i7-3820QM
32GB
SSD
Nvidia K2000M to external displays

Have installed latest drivers and put settings per other advice on various forums. I.e. set car to workstationapp streaming and max performance etc.

Issue is I have client sending me 75MB 2D lines drawings to manipulate (no meshes, surfaces etc) and it is taking forever to zoom and pan. Like 5 seconds to zoom to extents. Performance increases when zoomed in further, i.e. when less overall curves/lines on screen.

Any advice on settings to get things moving quicker when zoomed out? Driving me nuts!!


#2

I have the same issues with outboard engine models from my supplier. 90
meg. I try to shell parts out of the interior and keep their layer turned
off as much as possible. Perhaps the tech persons can tell us how to reduce
the file size by creating an outside surface only. Regrets, not much help.

In a message dated 4/13/2015 12:08:55 A.M. Central Daylight Time,
steve@mcneel.com writes:

 _wok_ (http://discourse.mcneel.com/users/wok)

April 13
Hi, Running Rhino 5 64bit SR 11 on
i7-3820QM
32GB
SSD
Nvidia K2000M to external displays
Have installed latest drivers and put settings per other advice on various
forums. I.e. set car to workstationapp streaming and max performance etc.
Issue is I have client sending me 75MB 2D lines drawings to manipulate (no
meshes, surfaces etc) and it is taking forever to zoom and pan. Like 5
seconds to zoom to extents. Performance increases when zoomed in further,
i.e. when less overall curves/lines on screen.
Any advice on settings to get things moving quicker when zoomed out?
Driving me nuts!!


#3

Hi @wok, Just a few thoughts of things to try:

  1. Are the imported items blocks? - Try SelBlockInstance and Explode the selection. (Repeat until none selected) ie. No Blocks left.
  2. Are the lines importing as thousands of line segments? - Right Click on each layer, then SELECT OBJECTS, JOIN
    Do This for each layer.
    Joined lines on my end perform much faster than many separate line segments. Michael VS

(Pascal Golay) #4

Hi Wok - one other thought is that the lines may have linetypes assigned, and these may be scaled so that there are far too many segements - a quick test would be to disable display of linetypes in LineTypeDisplay and see if things speed up at all.

-Pascal


#5

Thanks for suggestions.

tangofm - No surfaces just curves.

mvyess - No blocks. Some lines could be joined and made a difference thanks.

pascal - LineTypeDisplay made no difference.

I found some line heavy items on layers that could turn off (engines & equipment) - made a huge difference, which I should have thought of…

FYI:
226756 curves, 101 annotation leaders, 122 linear dimensions, 4 radial dimensions, 475 text

Intersting the same drawing exported to ACad, with all layers on, zooms and pans real quick. Appreciate horses for courses though!


#6

Here is a short screencast showing the speed difference when a heavy imported block’s layer is turned off. Exploding and joining the curves on this one hardly made a difference - I usually end up tracing around the perimeter - sometimes, drawing a rectangle around the exploded block and doing a CurveBoolean to the block exterior can work - usually not though as there are often lots of breaks in these imported files.


#7

Thanks Brian, Very interesting to see the difference in performance! Turning off non critical lines/layers seems the best option!