2 different outcomes - Loft


#1

Hello,

I’ve imported lines from another file. Loft them but the outcome is totally different than when I do it by hand. Settings are set the same:

What is the difference? Are UV or line direction changed?


#2

Rhino Applies a sorting routine when you select curves. Grasshopper sees the order in which you select them or by creation order.

You will need to sort them based on some sort of logic. My guess is a the Y component of the Start Point would be sufficient.


#3

When you loft curves manually with a window select, Rhino tries to figure out the direction and the order of the curves for you and make them uniform. With Grasshopper you need to make sue the curves all have the same direction and are in the right order before inputting them into the Loft component.

From your image it seems that the order at least is incorrect…

–Mitch


#4

Yeah that solved a couple of things. But I’ve just found out some Curves end’s are on the wrong side so they mess up my order. Is there a way to change make the end point the start points?

How to make an If statement in grasshopper? xD
Because then I can check if X start < X end then flip


#5

you could try [Flip Curve] based on the direction of the first curve in your list.


#6

Thanks got it! Loft is perfect now. Thanks guys.

Ill just ask another question here.

In rhino I can CageEdit or PointOn. Is there also a similair command in Grasshopper?


#7

No not really.

You will have to look into something like Box Morph where by you use a Bounding Box as your Reference and then a twisted Box as your Target. and slicing it up if you need to change it along the length.

An example of which can be found here: http://www.grasshopper3d.com/forum/topics/twisting-object?commentId=2985220%3AComment%3A961482

which was used for a twisting effect


#8

Good to know.
I’ve seen in that example that they “Group” a set of components. how do they do that? I’ve tried it with group but then i get the group command xD


#9

Nvm found it. Right clicking not a component…

Got a new one again. xD sorry for that.

How do I hide lines between components?


#10

You can also use the Space Bar to invoke the Radial Menu and select the Grouping tool from there

Right click the Parameter that the wire goes into and select either Hidden or Faint from the Context Menu