Yak thinks Rhino is running when it isn't

Many times when trying to use yak I find I get this message. My usual Rhino use involves developing Rhino plugins with VS. But this message appears when using powershell scripts or even just running things inside the command line.

ERROR: Access denied. If Rhino is running, close it and try again.

This happens even when I cannot see any Visual Studio or Rhino processes in Task Manager. Starting a new shell does not stop the error.

– cs

What are you running when you get that error? You say “yak” but what command?

Hey @brian ,

I’m using powershell to call the exe. Interestingly I tried uninstalling another gh plugin and that worked? I guess an error is being thrown that is being mislabelled?


– cs

Is there a Rhino.exe running in task manager? Could it be that Rhino is really running, and ghpt is loaded (but telepathy is not)?

Rhino isn’t running in task manager. And powershell cannot find it either.

– cs

Looks like we’ll need to get @will involved for sure.

@csykes can you try using handle.exe or Process Explorer to identify if there’s a process that is preventing those files from being deleted?

The directory itself is empty it seems;

It was sublime text :sweat_smile:. Thanks for the assistance will

– cs