Wrong size


screen capture here

My object should be about 7-inches long. The unit of measurement in the lower right of the screen indicates it’s in inches. But I sent it to a colleague and he says it’s coming in in millimeters. The dimensions are correct, just in mm not inches.

Hi - please post the 3dm file.

Did you send him the Rhino 3dm file or did you export it to some other file format?

I exported to stl

STL files have no ‘Units’–one of the reasons STL files are kind of garbage–so the software you sent it to assumed it was mm. Tell your colleague to open it as inches, or scale it, this isn’t exactly rocket surgery–yes tell them that.

1 Like

thanks for the knowledge. I “accepted my fate” and scaled it up assuming it was stuck in mm. Did I just double my problems? My colleague who is outputting to 3D printer, requires an stl.

Should I scale it up to the desired size in millimeters?
Or have my colleague scale it up?

I’ts simply scaling by 25.4, so…you can do that, export, then undo.

1 Like

As @JimCarruthers said, STL files are “unitless” as therefore assumed to be mm.
If you are going to have objects STL printed, plan on either modeling in mm, or converting your inches unit files to mm (scale up by 25.4) before you are exporting it.

I’m very surprised your colleague didn’t figure that out.
He must be new to STL printing too.

1 Like

Thanks for the tip. I’m less than 20 hours under my belt with Rhino, can you help point me to where I can scale up by a specific number? So far, I’ve just been dragging anchors—I’ve been trying to find where I can get more precise with my resizing. TIA

Start with the Scale command and look at the Help file article (start the command and tap F1).

The other option is to start a new file in mm, then insert your inches unit file into it, and you’ll be asked about scaling it by 25.4

1 Like