Wrong location snapshot when importing terrain from SketchUp

I’m trying to import a terrain from SketchUp with the snapshot to replicate later the building locations. No matter where I take the terrain from, the snapshot location shown seems stuck in a previous one. The only exception is a sketch file I used a few days ago which still open correctly. Any new sketch up file I import opens the same image. The topographic data seems to be fine as it varies according to the location.


Thank you.

Hi Nestor -
Could you explain what “snapshot” means in this context?
Also, perhaps you should attach a SketchUp file? From the information provided so far, I don’t understand what the issue is.
-wim

Hi,
sorry, I mean the image of the map that can be seen when you click in rendered.
Test_4.skp (990.4 KB)
For example in this case is a terrain from Scotland, but when I try to open it on Rhino the image I see is a cut from a previous file. This cut is not even the entire previous file as the error estarted with the that previous skp file importing only a portion instead of the entire terrain region. I’ve tried doing it with of regions and the result is the same image with different topography. The image below is from a different terrain but the map seen is the same as the one uploaded above.

Hi Nestor -

Are you importing different .skp files into the same Rhino scene?
If so, I suppose we’d need more than 1 of those SketchUp files.
At the moment I’m leaning toward different textures having the same name but I’m not completely sure of the workflow that you are using.

Also, please run the Rhino SystemInfo command and copy-paste that information here.
-wim

I’ve tried closing everything and start from scratch a few times. I use Geolocalization in SketchUp, then save the .skp and import to Rhino, It worked two days ago. Now the image shown in Rhino is always the same. I’ve tried closing it, unistalling it but no matter what skp file I try the image shown in rhino is always the same. Not enterily sure if it Rhino related, I’m starting to consider that the issue may be originated in SketchUp (but it still gets the topography correct).

Thanks!

Rhino 7 SR20 2022-7-12 (Rhino 7, 7.20.22193.09001, Git hash:master @ 9b19bfdb8c343dd6fa8df3514068defd72273d6f)
License type: Evaluación, build 2022-07-12
License details: Cloud Zoo
Expires on: 2022-10-15

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 6-1-2021 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1650 Ti with Max-Q Design (NVidia) Memory: 4GB, Driver date: 5-5-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.78
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-5-2022
Driver Version: 30.0.15.1278
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi -

It does sound like something that needs to be fixed in Rhino but I’m still not sure of the complete workflow here. And I also still think that I’ll need at least 2 different .skp files from you.

Importing your Test_4.skp file into a new Rhino document gives me the following:

That seems to be the correct result.
-wim

Yes that is the right topography. Here there are 2 other skp that I cannot open correctly, I think Test_3 corresponds with the profile from my first post (but not the images).
Test_3.skp (1.9 MB)
test_2.skp (3.7 MB)

This is the only one that I can still open correctly, though it was created a few days ago.
test_1.skp (1.2 MB)

I’m quite new to rhino so don’t know a lot and I may be missing something on options that appears when importing. Although my workflow is pretty much only that.

  • Open SketckUp
  • Geolocalization, save file
  • Open Rhino
  • Import the file, rendered view

Thanks for those other files, Nestor.
That’s clearly a bug in Rhino somewhere and I’ve written that up as RH-69604 for a developer to take a closer look.

In the meanwhile, you can delete the texture file on your disk to get a different SketchUp file to look fine. With any of those terrains selected in Rhino, go to the Properties panel and select the “Material” tab. Then look under the “Textures” heading and click on the “Location snapshot.jpg” link that is used for “Color”. This will pop up a different dialog box. Under the image in that dialog, you will find a field with “Filename” that can be selected but underneath that one is a “Found at:” entry. When you browse to that location in Windows Explorer, you can delete that file. The next time a SketchUp file is imported in Rhino, a new jpg file will be written here but that should then be the one that is needed for the file that you just imported. I hope that gets you somewhat further…
-wim

Yes it should help, at least in the short term. Thank you very much for all the help!

Do you have “embed textures in model” checked when you open/import the model? Since both image files have the same name, currently, I suspect the image file gets overwritten in the model. When you don’t embed them a directory is created with the file name so the textures can coincide even though they have the same filename.

Now it seem to work fine with both checked and unchecked embebed textures box for all the skp file, don’t know what changed though. Thank you.

Edit: After checking the skp files I have 4/7 open correctly with embebed texture crossed and 3 are wrong (always same image part from the first skp file I used, not included in this 7). When unchecking that box 6/7 open correctly and 1 is still that image. Not sure if that makes any sense, but I’ve tried going through every file I have covering both options.

Edit 2: Gone through all of them again trying both ‘import’ and ‘open’, now all of them opened fine. Still don’t understand it, but it works for me now.

Hi Nestor,

It has to do (I think at this point) with having the embed textures checked and importing a file into a model that already had one of these SketchUp (SU) files imported into it. The name of the image files in the SU files is the same so the embedded texture is either overwritten by the second one or the second is skipped because it has the same name as the first. When you don’t embed the files the complete path of the 2 textures with the same filename is different so it works.

This is a little bit speculative at the moment because I have not dug into the code but it has to be something like that if I’m not right.

Tim

Thank you for your time. Just to give all the info, when this ocured to me on wednesday I even unistalled Rhino, wouldn’t that delete any pre-stablished files from previous imports?

You know, I was just talking to Pascal about this and I think I experienced what you’re seeing. It must be some sort of image caching. Not something that the SKP importer does but I’ll dig in and see if I can figure out what’s going on.

You could also use the Heron pluginn for importing terrain models. Toghether with Human it works perfect.