Wish: Multi-Step Select Last


#1

I use SelLast all the time, but if the objects I want were created in multiple steps I can only get the last one. I can make ten copies of a line and then use SelLast to select all ten, but if I draw the lines one at a time I can only get one. I wish I could add more objects, stepping back through the most recently created objects the way Undo steps back through the most recent actions. Just keep clicking the toolbar button to keep adding objects. A multiple SelLast could work like Undo Multiple, with a drop down list of objects so one could pick all steps back to a chosen point, or perhaps pick them individually from the list.


(Pascal Golay) #2

Hi Mark- here is a quick try at a Python script that does this- double click the rhi file to install- you may need to close and reopen Rhino if you do this with Rhino running, not sure… If I’ve done it right, you should now have a new command SelLastMultiple- see if that does anything useful.

I see I cannot upload rhi files- please RENAME the zip file to the .rhi extension in place of .zip and then double-click. BTW, once installed, if SelLastMultiple is the first Python related thing you do, it will take a moment to load the very first time in a session but should be quick enough after that.

SelLastMultiple.zip (904 Bytes)

I’ll see if I can make a version that allows a click-click-click to add more to the selection, I like that idea.

-Pascal


#3

nice feature


#4

Pascal,
Thank you for this, I’m dying to try it out but I must be doing something wrong. The installer package says it installed okay, but I can’t invoke the command. I don’t know much about python, is there anything I need to do to enable the script? The installer did not add an alias as I, as a rvb would have.


(Pascal Golay) #5

Hi Mark- try closing and restarting Rhino. I have not always had the rhi system work 100% here either, but this one did install and work OK here after a restart of Rhino.

-Pascal


#6

Pascal,
I’ve tried restarting, installing with Rhino running or not, manually re-associated the rhi with both 64 and 32 bit versions, on two different computers. Can’t get it to work. I’m doing something wrong, or something is different on my end. Running build 11/13/2013.
Mark


(Pascal Golay) #7

Hmmm. I doubt you are doing anything wrong- it is either me, or the rhi system is not working quite right. Let me muck around here a little and get back to you. It installed and ran here so I thought it was OK to post - sorry about that.

-Pascal


(Pascal Golay) #8

Mark, please try this one and install ‘For me only’ for now, not all users… does that work?

thanks,

SelLastMultiple.zip (904 Bytes)

-Pascal


#9

Thank you Pascal,
how to make a button for this new command?
Or perhaps simpler RMB for SelLast command.


(Pascal Golay) #10

Hi violine- the command should act like any other command except that is it not localized, so no _ in front. But you can add it to a button just like any other command.
So, did the script install and work for you? I assume yes, but please verify…

thanks,

-Pascal


#11

Yes it works (the first one), as you said, I renamed the extension from .zip to .rhi, then double click with Rhino running, restart Rhino and that’s it.
Just one thing, what should I write in the button editor?


(Pascal Golay) #12

Hi violine -
You can just put

SelLastMultiple

it looks like Python commands are not nestable so it will just fail if you are calling it from inside a command, like Move. If you put a ! in front

! SelLastMultiple

it will work as a command but also cancel any running command.

-Pascal


#13

Works like a charm, thanks!


(Pascal Golay) #14

Hi Mark, violine- here is an updated version- it has two commands

SelLastMultiple
SelLastIncremental

Changes:
-Running either of these now runs SelLast (Rhino command) first. This allows me to select multiple objects that were the result of say, a Copy operation. The previous version counted these separately.
-SeLastIncremental starts with the SeLast selection, if any- (actually, I need to check that I catch the case where there is none…) then prompts the user to add items one at a time, marching back through the database.

Let me know if that is any good.
@Mark did you get any of this working??

As before: rename the zip file to .rhi, double click to install- for now install for ‘me only’.

SelLastMultiple.zip (1.8 KB)

-Pascal


#15

When installed it shows SelLastIncremental commad but then when you want to run it it says unknown command. After that is gone from the command list.


(Pascal Golay) #16

Hmmm. Obviously still some kinks in the process… perhaps… just a thought:

close Rhino, then delete the folder here:

“C:\Users\YOUR USER NAME\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\PythonPlugins\SelLastMultiple (57e4b1ea-e864-4b4d-a4bf-4af94de503d0)”

(with your user name in place, of course), and then install again… ?

-Pascal


#17

Omg, SelLastIncremental is the best, congrats, it is simple and effective :slight_smile:


(Pascal Golay) #18

OK, great… I have one or two more tune ups that I’ll post later (it is slow in some cases due to my being a dummy) … I guess at that time, delete the folder again, assuming that is what worked for you, and then install the renamed zip file.

-Pascal


#19

Pascal,
Well, I’m learning. I finally got the scripts to run, but I’m not sure the way you intended. I put the python files into my AppData Scrips folder, then invoke with RunPythonScript. SelLastMultiple was then available for reuse by command name, but Incremental only by calling the script, so I put a macro on a button for that. Now I see your hint for Violine, so I will try that and clear out the old data. I will get this working one way or another, because it is exactly what I have needed, so glad to have it! I had no idea this could be scripted, it is fantastic to get it now instead of waiting to see if it makes it into V6.


#20

Yup, deleting the python plug in and re-installing did the trick, everything working as expected now!