Why Wont Sweep2 work here?


#1

In the attached file are 2 closed curves.

Purple is a provided shape that can’t be changed

Black is an offset 10mm, slightly fixed where the offset loses the plot.

Can anyone help with why the sweep2 is failing? It thinks it’s working but generates nothing!

Is there a way to ‘fix’ the curves without changing their shape?

Is there a better way to go about making a ‘flat’ surface that extends 10mm out from the purple line?

Any help welcome as I’ve been going round and round with this and have no-one to ask. Thanks!


#2

Dave,
You have bad curves. They include infinitesimal line segments which are small enough to fall below tolerance, so the curves report as closed, but they aren’t really because of the extra open line segments. Try this: explode the curves, the purple will be made up of 14 segments, the black 12. Now rejoin them one segment at a time, they will both close with 10 segments. Window select across most of the curves, and you will pick up the little pieces and can delete them (SelShortCrv works also). You’ll still get a messy sweep unless you add more cross section curves, but at least it works. By the way, your existing cross section curve doesn’t touch the black rail, zoom in close and you can see this, probably not what you intended.


#3

Thanks Mark, it’s a simple thing but sometimes you get a mental block about the way to fix something.

Yes I will add more cross sections and the existing one isn’t right, I just threw onto the curves as I was posting the example, I have tried lots of varations in the drawing!

Appreciate the help!