Why do leader arrows now have multiple control points

Hi there,

With some of the recent updates to Rhino V6.13 there has been some weird stuff going on. I posted about some graphical problems and saving issues. The latest issue, which isn’t an issue so much as its tiresome and clumsy, is that now ALL leaders have multiple selection points at the tip of the arrow so when you select the control point the tool tip shows up allowing you to select the control point to manipulate shows multiple points. The kicker is not all of the control points that can be selected do anything.

Any thoughts as to why this is?

So far I can’t repeat that.
Here’s what I did:

  1. Make a new file
  2. Add a leader
  3. Select it to turn on it’s points
  4. Click at the tip

I’m not getting the ambiguous pick message for multiple points.

If you select one of the multiple points and drag it over a bit, what happens?

As in the image, if there’s three potential control points you have to find the one that actually does something by selecting one and dragging it and seeing if the actual control point moves. Most commonly its the last one in the list but that’s not always the case. This is also happening on other peoples machines that have the same Rhino build as I do here.

I was just informed by a coworker that this has been an issue since prior to this most recent update.

I’m running the Service Release Candidate for SR14.

I just made this file with a leader.
Does this leader have the same problem on your system?

CPT.3dm (26.1 KB)

Just tried your file and the leader issue isn’t happening. I tried making new leaders and it didn’t happen.
I copied and pasted the leader you made into a current rhino 6 drawing and it was fine, made another leader and the same problem arose. Seems as though something in the SR14 has fixed the issue.

You know how to get the Service Release Candidate if you want to try it?

Short answer is no, long answer is about the boss here, which I will not go into :yum:

In Rhino Options > Updates and Statistics, you can change the update frequency from Service Release to Service Release Candidate.
Then you’ll get automatic updates almost every week instead of once a month.
You can switch it back when you want to.

Another option is for me to email you a direct link to the current SRC build you can download and install.
A new one went out just yesterday.

I’ve had a similar issue, but only with leaders that have no text…

4 posts were split to a new topic: Random changes in annotations

Still happens to me that I can’t move leader tip easily…

First mouse click

second mouse click


This was totally new Rhino window opened, so nothing else there but leader.

Leader 1.3dm (24.7 KB)

CPT worked normally for me :S

Is it some setting which is wrong or bug?

I see that - bizarre. Window selecting all three control points works to move the arrow tip in the meantime.
@pascal? V7 works correctly for this.

Hi Wagner -

I see that here on Rhino 6 as well and that seems to be a bug, yes.
As Mitch points out, this works correctly in Rhino 7.
I’m afraid this is not something that will be fixed in Rhino 6.

Yep, I think that is this one -
RH-61093 Annotation Leader: Blank leader shows extra points at the arrow tip


Nice to hear that it works correct in R7. Moving to R7 before 10.3.2021 :wink: