What setting will snap to only on the selected object or dimension etc?

My snap is being distracted by a myriad of mesh triangles when the item I wish to snap to is for example sitting above the mesh and I am in top view.
Even in normal scenes with many objects I may wish to select an object then have snaps operating just for anything selected.

How is this done please.

P.S Hope you are all safe out there, beware normal masks have no protection value to the wearer.

Uncheck the “Vertex” object snap.

There is no way to limit the object snaps to just a selection of objects.

You could hide all but the selected objects so that only they are visible while doing your operation. V7 is better than V5, as it has the Isolate/Unisolate commands.

Or, if you want to leave everything visible, you can right-click the checkbox of the object snap you need to make just that one active. Right click again to restore the previously active object snaps.