Web Interface "Api key was not provided"

Hello everyone,

I’m trying go to the ip address for my Compute server through a web browser. When I go to the ip address I’m met with the error “Api key was not provided”. Is there a way to add the api key as a parameter to the url so I can access it?

Hello. Have you followed this guide: Rhino - Deployment to Production Servers ?

Sorry it has taken me 8 months to respond, life happened :upside_down_face:.

I am still having this issue and have followed the instructions in the link you posted to set up the compute server, with the one difference being that my VM is setup on a Hypervisor on our company network instead of being hosted by AWS/Azure.

I get the error if I go to http://<compute_server_ip>:80 on a workstation or the server itself, and I also get the error if I go to http://localhost:80 on the server.

The compute server itself functions correctly, I am able to make calls to it with Hops from a client machine without issue.

If you’re using an app like Postman to send requests, then you can include parameters in the Header section (see image below). The key should be called RhinoComputeKey and the value is whatever API key you set as an environment variable on your VM.

Alternatively, if you’re using a client like Hops to send requests to your server, then you can set the API key in the Hops preferences section. To get to this dialog, Open Grasshopper and goto File->Preferences->Solver.

1 Like