Walls Joints issue

Hello,
I’m not able to create this joint walls…it’s a VA limitaiton or it’s me?

Hi @lopez, please share the file so we can figure out why this connection is not working as expected.
Check the “Sort Order” options, in the Wall joints panel, after selecting the three walls, in the Properties panel, just in case it provides a better solution:

image

Hi Francesc,
thanks for your message.
Here’s the Rhino/VA file:

VA Walls issue.3dm (3.9 MB)

Hi @lopez,
This is what I get from your file, after changing the elevation of the Floor 1 to 0 (since it was set to 600, and the cut plane was not cutting through the walls), and after extracting a piece of solid from the wall (using the vaExtractSolids command)

What VisualARQ version do you have?

Hi Francesc,

I have the attached VA version.

I don’t understand good your reply…I mean what happens to leave my model and not cutting it (I used 600 to not cut it)? In your example, there are 2 lines on the wall that in the 2d prospect drawing create confusion because it seems you want to design/to communicate that there’s something that doesn’t exist in reality …
P.s. It’s possible not to visualize those 2 lines from the 2d prospect representation?

VA license

Hi @lopez, it’s just that in order to reproduce the error, I need the model exactly in the same situation as you are getting it.

This is what I get from your model, after activating the cut plane in the Top viewport:

After I change the Floor 1 elevation to 0, I get a correct intersection:

(As you may appreciate, I also don’t get those two lines as in my previous post)

So could you try to reproduce the error, save the file, and send it again?
Thanks!

Hi Francesc,
could you please send me your file? It’s faster and I can understand what I was doing wrong, thanks a lot,
Roy

Hi Roy,
Sure. Find it attached here. I just changed the Floor 0 elevation to 0, and activate the cut plane in the Top viewport.VA Walls issue REVISED.3dm (3.9 MB)

Yes, now it works!
Anyway, I’ve tried to create a 2D plan (cutting at 600) and I see 2 lines on the wall joint at the left as in the image linked (in the Top model view I don’t see them). It’s the same file, only create a 2D plan cutting at 600.

Hi Roy,
I got those lines too. I’ll report that to developers so they can see what’s going wrong.
I’ll get back to you when I know more about it.

Please consider the option to use real-time plan views with the Hidden display mode (where you don’t have this issue), instead of the 2D plan views.

Ok!
Anyway, it’s possible to manipulate the 2D plan view by deleting for instance these 2 lines? I mean, if I have some issue with the 2D views I can only solve it only inside the 3D model?
And in what case do we need the 2D plan views instead of the real-time plan views (I mean why do we still use the “Make 2D” views as usual in rhino?

You can explode the 2D Plan View, and delete the undesired lines. Of course, this will break the connection of the 2D view with the 3D model.

You currently need that if you want to export the 2D drawings to dwg (the option to do it with real-time views from page layouts is planned for VisualARQ 3).

Also, if you need to modify the appearance of these 2D views, it is more customizable to do it with the resulting 2D geometry after exploding the 2D plan/section views, than from the real-time views.

But if what you see in the reat-time views is already fine for you, then I recommend using it so you will get lighter and faster files, and less errors in the correlation between 3D model and 2D drawings.

Ok, thanks!
It is not yet configurable the project patterns of the objects , right?
Do you know when it will be available the R3 (approximately, of course)?

I mean the pattern in the projections views…

Hi Roy,
VA developers have figured out that the reason why you see those lines in the plan view:
Those lines are from the surface where the wall has been extended to. But they are not visible in Hidden display mode (nor in Conceptual or Realistic). The surface has 2 edges that are not tangent, so they must be always visible. They are visible in:

  • Make2D
  • Technical display mode
  • Shaded display mode (even turning off “Tangent edges” display option
  • plan and section view

We will fix the bug so they appear also in “Hidden” (and “Conceptual” and “Realistic”) modes. In the meantime, you can un-extend the wall, and extend it again to a surface that doesn’t have those edges. Finally, you can update the plan view.

That’s not yer available. It’s a feature planned for VisualARQ 3. We still don’t know when we will release it, but at least 1 year.

Thank you Francesc