Viewport constantly panning down of its own accord

V5 - I’ve just started having a problem with the active Rhino viewport slowly panning down the screen when no command is running. It does it very slowly - 2-3mm per second, maybe - but it’s making Rhino almost unusable. Task Manager is showing high Power Usage the whole time Rhino is running. The Layers and Properties are often going completely blank, but if I click in them the item picked becomes visible. Inactive viewports are stable.

I’ve tried unplugging both mouse and keyboard, without effect. I’m not seeing strange behaviour in any other applications I’ve got running.

This has never happened to my Rhino before. Any ideas what might be causing the problem?

Hello, MattE,

I have on occasion had a similar problem but only in Raytraced mode and in the Front and Right Viewports. At first Raytrace has difficulty starting cycles. Then when it starts the model rather quickly pans out “slips out” of the viewport.
The basic model object characteristics:

  • They have 3D texturing - one object is just a rectangle of a 3D texture ( 4 naked edges)
    The other is a closed polysurface with a 3D texture applied to one face. It seems to be a valid object without problems.

  • It seemsto be a big file (142 MB) given the size of the mode (2 objects): e.g. one aprox. .5x.5x.3 cm

The video card is a Nvidia p4000 ; 8GB video RAM ; Machine RAM 64 GB, Rhino 7, Win 10

In Raytrace mode with 4 viewports, if I set the Perspective and Top Viewports to Raytrace the machine uses about 80% of the cuda cores , 4.5GB of Video RAM and 24% of system RAM (~ 14.GB) with a browser and some other apps running.

Without going any further into “the weeds” I have a feeling that this behavior is a hardware issue. The video card is starting to reach it’s end of life cycle.

Thank you,


Hi Matt - is there anything other than a standard mouse connected to the PC, like a 3dConnexion deal?


Hi Pascal - No, my 3D Connexion mouse isn’t connected atm. I’m not aware of any recently installed updates or changes to the system either.

When I call a command, the scrolling stops, but Rhino seems very sluggish to respond. As soon as the comand ends or is cancelled, the scrolling starts again. It happens with ortho or perspective views - whichever is the active VP.

When Rhino doesn’t have focus, the scrolling stops. As soon as I give focus back to it, it starts again.

Any plug-ins installed ? Can you run SystemInfo in Rhino and copy paste the results here?

Does SystemInfo work in V5?

It’s brought to light another aspect of the problem though: Typing in the command line is almost completely unresponsive. If I’m lucky, I’ll get the first couple of characters typed and then the viewport scrolling is triggered. Once it starts scrolling, I can no longer type. It’s as though there’s a command continually running in the background.

I’ve updated the graphics drivers to the latest version but that’s made no difference.

Is there any kind of installation repair routine I can run in V5?

Did you try this (seems like this is pretty buggy Win feature, just a wild guess if you have it on it might have started causing this)

Hi Jarek.Thanks for the suggestion. I found that on a google search yesterday - I didn’t know it existed. Unchecked it; rebooted; no difference, I’m afraid. In any case, I find it a very useful feature as I can scroll long sheets in Excel on one screen and still be able to type in Rhino on another.

I ran a Windows sfc /scannow. A couple of minor repairs found but I don’t think they’d have any effect on Rhino.

Something that has just happened though: When I rebooted and opened Rhino, the scrolling started immediately this time - I didn’t have to do anything to prompt it. After a couple of clicks into the Options menu, the command line came up with “Script cancelled”. I hadn’t called anything. I’ve only got six scripts loading at Rhino start and they’ve been there for years, without a problem.

Is there any way I can find out exactly which script was cancelled?

Hi Matt,
did you try running Rhino is Safe Mode? (wondering if this happens as well there - if not, maybe it is plugin-related)
No idea about the script canceled, unless you have some startup scripts defined (you can check this in Options > RhinoScript)

It may be helpful to run and paste here SystemInfo as Mitch suggested.

I remember this happening to me a couple of times when using the 3DConnextion device, but it was only because I pushed it aside and it was leaning against an object on my desk and “moving” on its own. I see you don’t have it, so that’s ruled out.


1 Like

Well, if you’ve only 6, you could remove them all, restart Rhino, and then if the bad behavior has stopped, add them back one at a time and see when the bad behavior comes back… Then it’s time to diagnose what is wrong with the script.

The six scripts are all well known and written by people that know what they’re doing (i.e.: Not Me :laughing: )

I’ll give Safe Mode a try…

Quite an annoying side effect of disabling that mouse setting for scrolling inactive windows: You can’t mouse scroll the programme list that pops up from Start.

yeah, if that did not help you can probably turn it back on

Is it panning by itself regardless of the type of view or is it panning a parallel view and rotating a perspective view?

What are your specific input devices?

This is really weird, but my guesses for any sort of input problem are “some Windows ‘accessibility’ feature that has been accidentally turned on” or “hardware failure.”

Not dependent on type of view - ortho or perspective, it does it the same. Only the active viewport is afflicted.

It’s also pretty random. It doesn’t do it all the time, but once it starts, I can’t find a way to stop it. Repeated “Esc” or Return has no effect. I can carry on working when it’s doing it, up to a point. I can zoom, pan, select objects, draw geometry. However, at some point (again random), having a single piece of geometry selected makes the Properties panel go completely blank. If I’m for example in the middle of typing in the Name field, Rhino becomes unresponsive and CPU load goes right up. It’s as though there’s a command repeatedly running in the background and unless my keystrokes hit the gaps between it running (the viewport is panning down with a kind of crawl - very small increments, not smooth movement - looks a bit like dot crawl when I’m zoomed out).

I haven’t found a reliable trigger to start it off. Sometimes it does it from the monent the file opens; sometimes not. I’ve got a single instance running in Safe Mode atm. So far, I haven’t been able to provoke it into panning. Must admit, this one’s confusing me.

Well that sounds like a misbehaving plugin.

Well - I’ve tried disabling a few plugins. Sad to say, the most success comes when I turn off Peter’s Tools (for V5) which I see from his Wiki page has now been deprecated; it’s not available on the Food4rhino page.

However, I am still getting the scrolling, but nowhere near as often. So some other plugin could be suffering with the same problem. It’s happened once in the last 3-4 hours, as opposed to once every minute or so. So it’s probably time for me to retire Peter’s Tools, for V5 at least :cry:

I understand your 3D mouse is not connected, … can you uninstall the driver to see if that makes any difference?
I seem to recall having this problem a few years ago and my first thought was something is pushing on the mouse but that turned out not to be that case. It took an uninstall and reinstall of the Connexion driver to fix the problem.

Presumably you would want to download install the latest Connexion driver.

1 Like

Well, time for me to humbly apologise to Peter and his awesome Tools. The unwanted scrolling has started happening again today and Peter’s Tools weren’t loaded, so I spent a while disabling pligins to find the true culprit. @cdordoni - you’re right. It’s the 3DConnexion driver. Specifically, it’s the Pan / Zoom that’s causing the problem. If I disable that in the Navigator menu, the auto-scrolling immediately stops. Curiously, if the radio button in the spacemouse menu is set to Object mode, the active viewport scrolls upwards. If I select Camera mode, the scrolling immediately changes to scrolling downwards. Proof positive, if any were needed, that 3DConnexion is the cause of the problem?

Peter’s Tools meanwhile, have been fully reinstated. Deservedly so.

All this is in V5. Not a problem in V7.

1 Like