View Mode Shows Default Grey Background in Detail View though set to Solid Color Black for Background

It shows the solid color in the model viewports, and layout space, but it’s only visible in a detail window when it’s activated.

The view mode shows set to a black solid colour background in display tab and Options.

The behaviour is the same whether the black is 0,0,0 or 1,1,1; and regardless of how the cplane is set.

6.8.18219.371, 08/07/2018

I’m not totally sure if I’m following you…
The color of the sheet of paper that you see in a layout is the one that you set under Rhino Options > Appearance > Colors > Viewport colors > Layout.

The setting I’m talking about is OPtions>View>DisplayModes>DisplayModeNameRoot>ViewportSettings>Background>SolidColor>ChosenColor

The behaviour’s present in both shaded and rendered view modes. (I don’t know if it’s limited to them.)

Having chosen bright green as an example BG color in the view mode common to both layout space (I don’t care about the color of the BG of layout space, but it shows that it’s working) and the detail (where I want it to always show). It’s visible in the detail as desired here when the detail view is active:

but it’s gone from the detail (though still in layout space) when the detail is no longer active:

It’s always present in the viewports as well. Just not in an inactive detail view, where I need it.

What you are seeing there is the paper color, yes.
You can change that under Rhino Options > Appearance > Colors > Viewport colors > Layout .
Alternatively you could experiment with a colored plane in the model space.

I’m seeing the paper color through a transparent background when the detail is inactive, yes. And I’m seeing the background color I’m after - the one I’ve set - when the detail is active (only).

Changing the paper color to greenturns the entire layout sheet to green here along with the background in the detail. I want to control the detail’s background color independently of the background. In this hypothetical example I’m after it being green on a paper-colored (white) layout sheet.

I think I understand you, but I’m still confused. The background in a detail view is transparent if the view mode’s background is set to a solid color instead of transparent? Then what’s the intended result if it’s set to transparent?

Setting up planes is several steps. Seems to me the colored background is a good universal solution to distinguishing any spaces in view beyond a scene. But it only works for a viewport when set, not for a detail view?

Hello - for a print, in case that helps, you can show the background color but so far not in the Rhino display when the detail is not active, as far as I can see.


THanks Pascal. THat makes it workable.

(but I think it compounds the confusion about how it’s intended to work. e.g: does that setting override any “transparent” setting on the b.g? experimentation will clarifity that, but the interaction of these settings might just be a little too cumbersome for most to figure out.)