Very slow InsertEdge

Hi
It works very slowly when executing the InsertEdge command

Rhino 7 SR0 2020-1-6 (Public Build, 7.0.20006.18535)

2 Likes

?? :point_up_2:
@pascal
@BrianJ

Hi @mehran09197306634me , I think this is due to the number of edges in the loop. I’m seeing the speed drop when there are around 80+ edges in the loop. Is this the case for you as well and does it work quickly enough on less than 50 edges in a loop? Also, this slowdown due to edge count is only seen with SubD objects correct? I don’t see the slowness with meshes of the same density.

Filed as https://mcneel.myjetbrains.com/youtrack/issue/RH-56499

1 Like

Hi @BrianJ
I did a lot of testing, even in the simplest of objects, but it’s slow, but not in the mesh
thx

Okay thanks, please send a 3dm file with a simple SubD that is slow for you with InsertEdge and the results of your SystemInfo command. Email tech@mcneel.com if it’s anything you can’t post here.

1 Like

Thanks
@BrianJ

bug.3dm (1.0 MB)

Rhino 7 SR0 2020-1-9 (Public Build, 7.0.20009.17365, Git hash:master @ 51b6b268a68844793ad502137f4b4d7d167f5324)
License type: Commercial, build 2020-01-09
License details: Stand-Alone
Expires on: 2020-02-23

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: CHAOSGROUP

Hybrid graphics system.
Primary display: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 960M (NVidia) Memory: 4GB, Driver date: 10-22-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.08

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-22-2019
Driver Version: 26.21.14.4108
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20009.17365
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7 WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7 WIP\Plug-ins\Pangolin.rhp “Mesh2”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20009.17365
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20009.17365
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20009.17365
C:\Program Files\Rhino 7 WIP\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.0.20009.17365
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20009.17365
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Mehran 73\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\rhino-render-next\0.0.2\RhinoRenderNext.rhp “Rhino Render Next” 0.0.2.0

!!!Even sometimes it causes it to crash

Thanks, I added your file to the bug report. I am not seeing slow InsertEdge performance on the simpler SubD in your file though.

1 Like