UV editor / Cover mesh issue ?!

Hello Rhino users,
I try to unwrap closed poly surface using UV editor, but I have result shown on picture below.
Any suggestions?

That does look odd, can you post the 3dm file or just that part of it?

front-part-01.zip (3.8 MB)

Hello Brian, thanks for support.
Model in zip archive, re saved in Rhino4 format attached.


If you look closely you’ll see that in the cover the inside part is selected. What you see on the outside is not the part of the texture that is selected. If you’d rotate around the wheel cover so you can see from the inside you’ll see that the texture matches.

In your own screenshot you can see you are not looking at what you think you are

The correct part for the outside of the wheel cover is elsewhere

1 Like

Hello nathanletwory,
thanks for the reply.
All 4 similar surfaces got same issue.


So I guess the problem you’re highlighting here is that the round opening in the wheel cover is not round in the unwrapped mesh?

Edit: I wonder how you unwrapped this? Probably missed something while picking seams? I did a new unwrap and that gives good unwrap on the wheel covers

Thanks for reply once again.
Do you mesh object before unwrapping?

How I’m doing unwrapping:

  1. Select NURBS object
  2. Click “Texture Mapping”
  3. Click “UV editor”
  4. Draw square where surfaces should be projected.

This is the only way I know. Basically it works …

Can you please tell me how you get such a successful result?


Between your steps 2. and 3. I clicked on the icon with the giftbox being unwrapped.

This video tutorial may be of interest too…


I tried gift box button,
but result was tiny line or abstract art shown below.
But yes, I got this surface properly unwrapped :slight_smile:
Witch options you used?


I selected all edges as seam edges. If you take some time to properly select the seams you can ensure better unwrapping with the gift box.

nice video - well done - i will send the link to my students. thanks a lot for pointing out this nice comprehensive overview.
one side-note: watching your video (recorded on 24 zoll ?) on a 16zoll laptop will be not that easy to follow, because the toolbars are quite small.
can you post the model ? thanks - have a nice eastern holiday. -tom

Great! It works! Thanks!

Since those unwrapped surfaces are rotated on some angles and osnap does not work, how can I align them?


Hello- Vertex osnap should help.



Hello Pascal, thanks for reply.
Vertex osnap option DO work!

Thanks to all for support!

Hi @Tom_P ,

Thanks! In the Help menu in Rhino 7 > Learn Rhino > Sample models, check out the SubD sneaker model there. It’s almost the same exact model, I just changed a few objects into NURBS with ToNURBS or meshes with Mesh to show mapping workflows on other object types.

Yes, screen resolution can be an issue when viewing 4K videos on lower res displays. Maybe casting it to a TV would help? I’ll experiment with icon sizes in the UI and see if I can find a happier middle ground but it’s a balancing act for sure.

Thanks! On it!