Update video driver

This is cute…

More importantly, did the message work?

The existing drivers work…

Same experience here - existing drivers seem to work, and my machine won’t allow for the driver to be updated to 340.66 or 340.86 (if i remember correctly).

Could this warning be convinced that it’s been read/understood?

I actually liked the message and found it worked well. Sure, the existing drivers were working, they were updated not long ago, but presumably these will work better so why not? What I liked was that the pop-up told me what drivers I needed and took me directly to the page to download the 340.66 drivers, I didn’t have to search them out myself, so the whole process was painless.


One of the biggest problems we have had in Rhino is stability issues with the Nvidia Cards video drivers. We were able to work with Nvidia on both the stability and the speed of Rhino with these newer drivers. Both Rhino and the Nvidia drivers changed based on this collaboration. So, while the existing drivers may work well, we also believe newer drivers will show some performance improvements.

What version driver are you currently running?


Hi @brian

This is not always desirable as some of us are running Autodesk software and are relying on having Autodesk Certified drivers for those applications.


Interesting. Is the 340.66 driver not certified?

I’m really torn here: drivers pre 340.66 are the single biggest source of crashes in Rhino when users have Quadro cards. Running with older drivers is, as far as we can tell, an great way to lose your work.

But perhaps it’s less common than we thought. For those of you who are really opposed to using the more stable driver set from NVIDIA, I’ll add a way to hide that dialog box.

Hi Brian.

With NVidia cards up to the K4000, Win 7 64 bit, for both AutoCAD 2015 and Revit 2015, the last certified driver is 331.82 directly from Autodesk

I do really appreciate your concerns and efforts but all the certifications become a bit tricky.
I run hp workstations and hp also have certified driver lists, but generally in unison with Autodesk.


It might actually be the time to run separate systems.
I have always kept my “main” workstation for CAD and my ‘secondary’ for all other works.
Perhaps it is time for AutoCAD / Revit system and a Rhino system.
I provide CADD Services to others and all three programs are invaluable and uses differ from one project to the next.
An absolutely awesome trio.


Just one question: I already have 3.40.84…I then installed 3.40.66 to get rid off that nagging box.
It still exists, why?

Great work brian!

That is good, some users will need to use older drivers for various reasons.
But I vote for a “remember this setting for 2 weeks” option, rather than a " DO NOT NAG ME AGAIN!!!" option. :smile:

Or find a way to hide it, and reactivate it if Rhino discovers that it was recovered from a crash. (Rhino already does that, so it should be possible)

That’s not good at all - we’re supposed to recommend replacing drivers OLDER THAN 340.66, not different than. I’ll see if we can reproduce the problem here.

@scottd can you please test this?

Matti -

I would like to setup the same problem you are seeing on my machine. Could you help me with some details about your system?

  1. What Operating System are you running? 32 or 64 bit?
  2. Which Video card?

I will try and duplicate the problem here.

So basically what you’re saying is we need to treat users like children… This message should show up ONCE, and be repeated only if Rhino crashes afterwards. I will update my drivers when I feel it is necessary and I have time (and especially if I’m having problems in that area) but I don’t need to be reminded of it every time I open a new instance of Rhino (dozens of times a day).


So, when I click on the link from the Rhino nag screen I get the following page:

Nowhere on that page does it say what driver I am actually downloading. On the “Save as” dialog, the title is there, but it’s so long the driver number doesn’t show up either… OK, after downloading I see it’s the 340.66 driver, but the current is now 340.84. I would like to install that as long as I’m updating, but apparently the nag screen will still appear according to matti. Well, I’ll take my chances and test to see if that’s still the case…

Edit: @matti_orpana 340.84 installed and no nag screen, so far so good.

@scottd my current install is 333.11 from May…

Thank you for testing this. Is see the 380.44 is working on your machine. I expect @matti_orpana is a problem with a specific operating system or card model.

Unfortunately, Rhino can’t tell when it crashes due to a video driver (unless we install and run a debugger on your computer). I can add a “Don’t show me this again” checkbox, but after you check that, you are on your own. Unless any crash should trigger the dialog to appear again.

Clearly we don’t have good enough statistics to determine the severity of this problem: we know we see lots of these crashes, but we don’t have good numbers about how often Rhino doesn’t crash with older drivers.