Understanding why this Boolean Difference won't work

I’m a learner, and have drawn up this model sailplane stabilizer, and am trying to subtract it from a mould shape to create a female mould. I’ve created the “trough” just behind the trailing edge and it subtracts OK, but the boolean difference fails for the wing shape.
Angry Bird stab mould.3dm (2.2 MB)
I’m really at a low knowledge/ experience base, but by research I’ve identified various problems such as naked seams and fixed them, so now both shapes report as valid closed polysurfaces.

Any advice? I’d really appreciate it … this is the main sort of modelling that I need to do when I get my CNC machine so I really want to know it well.

Much appreciated,

The intersector is having trouble with the large surface… I’ll take a look and see if I can figure out a way around this.


Great, thanks Pascal. Is that always a problem with Rhino or is it an OSX issue? Is there away I can avoid such problems in the future? Because this is only a small surface and one of my other projects is a much bigger full span wing.

I would love to see more feedback in the UI for why boolean operations sometimes fail. I’ve often run into this, and I think it’s because I have non-closed surfaces or something? But all the UI says is that the operation failed, with no reason why, so I’ve no idea how to fix it.



Here is some useful information on Boolean Operations… Rhino doesn’t necessarily inform you as to the reason why Booleans fail - they can be complex. The #1 reason is that Rhino has not found a complete and clean intersection between the objects - without that, it will certainly fail. So the first thing is always to check the intersections by running the command Intersect.

The other problem is that MacRhino is just poorer at giving the user feedback than Windows Rhino is… In Properties>Object, for example, it will tell you that an object is a polysurface, but not if it’s closed or open. You have to go into the “Details” tab and wade through the info there for that. And I’ve often found that the details panel is blank (I assume this is a bug).


1 Like

One observation. I used your model and found the same problem that you describe. I then made a slight adjustment downward with the wing and the boolean difference worked fine. I also created a second, larger block and made multiple copies of the wing with different orientations and the boolean difference worked fine then too.

Tom, thanks. It seems strange that moving it down would affect it. I’m not sure what to do … the wing has to be set up perfectly on the construction plane, which is to be the mould parting board line. Anyone else got any ideas?

When you move it a bit upwards, you 'll see that it will work.

Thanks very much. I drew up a new mould block shape and it worked fine this time. I’d be interested in any constructive criticism if anybody wants to have a look. I hope to get this cut out on a CNC mill this week! It’s fully symmetrical so I should be able to cut the same shape twice, for top and bottom. Angry Bird stab mould v2.3dm (3.9 MB)

Hi Andrew- I was not quite sure, in the earlier file, what was supposed to happen along that slot at the trailing edge- the main surface did not, quite, reach all the way to the slot. At any rate, I would ExtractSrf the vertical walls of the slot and run DivideAlongCreases (both options set to Yes) to split up the surface into a polysurface, then rejoin it all to the main object- meshing will work better, possibly other things as well, depending on that happens next for this part.


OK great, thanks Pascal. The slot (trench) just needs to sit adjacent to the trailing edge, to give a defined corner.

I’ll have to check out ExtractSrf as I haven’t used it yet.

Much appreciated, Andrew

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

I have absolutely no idea how this post got here. I haven’t even logged
into the McNeel forums for a long time, and I barely know how to use
LinkedIn and almost never look at it. I did accept an invitation on
LinkedIn the other day and perhaps I inadvertently clicked on something
that gave it access to my accounts?? But I don’t think so. I don’t
understand, and I’m really sorry.