Unable to load plugin: application initialization failed

I’ve got an issue with a plugin I’m developing. It used to load properly in Rhino6 but I stopped working on it for a couple of months and now i’m stuck with an error “Unable to load plugin: application initialization failed” when trying to load it.
I’ve tried with the same .rhi installer that used to work, so it should not be a missing reference issue.

Is there any way to get more debug info on plugin load time than this empty error message?
Thanks for helping

My installer just in case:
MarineStructureWorkShop_0.5.2.0_WIP.rhi (4.0 MB)

Let me know if you need to have a look at my source code.

Windows does not recognize anymore my .rhp files as rhino files, I have to do “Open as…”.
Could it be related to my issue?

Hi @Matthieu_from_NAVINN,

Version of Rhino the plug-in was built for
does not match the this version of Rhino.
RhinoCommon SDK Version = 5.1.30000.17
Plug-In built for version = 6.12.19016.7051

Perhaps you should build your plug-in against Rhino 6?

– Dale

Hi @dale, thanks for your help.

The plugin is built against RH6 and the installer I sent to you used to work with RH6.
But there is something wrong somewhere indeed: this morning when I tried to run it for the first time, I tried to open the .rhp with rhino6 (“Open as…” windows contextual menu), and rhino5 started instead.
After that I uninstalled Rhino5, but Rhino6 still won’t load it.
Since it used to work my guess is that my rhino installation is messed up, I’ll try to uninstall then reinstall.

It’s not the first time I’m having issues to figure out what prevent a plugin to load (or commands to register), is there any way to get some kind of trace or error feedback from Rhino concerning the plugins’ background operations? (Some kind of debug mode for third party developers?)

Good morning @dale,
My loading issue was actually a fail in my code. There was a date limit set on the plugin’s OnLoad() overrides. I used it as a basic license limitation when releasing a WIP plugin and forgot about it.

I still had to remove and clean install Rhino6 though, and I’m still interested if you have a way to get a feedback on Rhino’s plugin related crashs.

Best regards