Trying to make closed mesh (or polysurface) from the resulting geometry of this GH script

rhino
grasshopper
unhandled

#1

I’ve created something I liked using the GH script explained in this video https://www.youtube.com/watch?v=4mSvI53vfJ0 and the result is a group of open mesh which I then joined into one. The end goal is to 3D print this but the mesh that is baked has no thickness and I’m trying to figure out how to make it a closed 3D object.

I’ve tried doing an OffsetMesh with the baked geometry and that produces a closed mesh (or closed polysurface if I do MeshToNurb before the offset) which clearly looks like it contains multiple naked and/or non manifold edges. I’m hoping that someone might be able to take a look at this script and tell me how it could be modified so that the geometry the GH produces would be a solid/group of solids rather than a group of meshes or surfaces.

Here are screenshots of the script and its baked geometry as well as some zoomed in before and after’s of the offset that show the messy edges

Also attaching the GH file and rhino model

180213_Paneling_02.gh (13.3 KB)
180213_Paneling_02.3dm (463.9 KB)


#2

Hi @lauxnt,

Offsetting any faces with valence higher than three at the nodes in non trivial, since there are many solutions to the plane1/plane2/plane3/plane4 intersections. Rather than thinking of this as face offsetting problem i would suggest this can be solved by offsetting topological edges. Cytoskeleton offers a fantastic solution to this using the Half edge datastructure implemented in Plankton

I have attached a solution using these add-ins.
180213_Paneling_02-Plankton-Cytoskeleton.gh (19.3 KB)
180213_Paneling_02-Cytoskeleton.3dm (747.2 KB)

Hope this helps!


#3

Hi. @lauxnt
You should flatten “M” input of Mesh Join and add Weld Mesh or use Weaverbird’s Join Meshes and Weld for a decent mesh thickening.
I’ve made a copy of your final mesh for the output comparison.

180213_Paneling_02_re.gh (19.4 KB)


#4

Thank you so much, this looks like it’s exactly what I was looking for. Regretfully I do have to ask a stupid question because I’m a such a GH noob (for now). I’m pretty sure that I placed the GA and .dll files for Exoskelton and Plankton in the wrong location because I got a component exception error message when I opened your grasshopper file and I can’t preview any of the GH script in the Rhino window.

The only other extensions I’ve installed for GH thus far were the MeshEdit tools and I put those in C:\Users\Nate\AppData\Roaming\Grasshopper\Libraries
Do I need to put the GH assembly and App extension files in a different folder in order to see and modify the script before baking into Rhino?

Thanks again


#5

Have you unblocked the dll and gha? I’m not sure what this error means. Maybe the versions are different?


#6

Not sure what that would mean to “unblock” the dll and gha. Could you possibly link the plug in files for Cytoskeleton and Plankton that you have installed for your software? I know it sounds silly but maybe you’re right and I downloaded a newer/older version of the ones used in the file you sent me.

If you can’t post those on here for whatever reason you could always get my email and send me a WeTransfer link


#7

When you download a file from the internet, by default the OS will protect itself from it by blocking it.
Right-click on the downloaded files, pick Properties at the bottom of the menu.
image

Then click Unblock in the dialog box.

Latest versions of Plankton and Exoskeleton are here: