Trouble with sweep


(Erikr) #1

For a few months sweep1 and sweep2 have been acting wierd. Now sweep1 making crappy surfaces. It never used to be like that. Don’t know what is wrong. Please help.

BAD SWEEP1.3dm (572.0 KB)


(Pascal Golay) #2

Hello- It looks correct here - you’ll want to make two separate sweeps, you don’t get to make two shapes at once - Sweep1 will try to combine the profile curves.

-Pascal


#3

The surfaces will look better if you run DivideAlongCreases command on these.


(Erikr) #4

I did originally sweep each shape separately. Sweep1 has been making what looks like twisted surfaces. Sometimes they come out as polysurfaces and sometimes a single open surface. An example would be a 3"x2"x.1875" extruded angle, where .1875" is the material thickness. That has been coming out with twisted looking facets, some of the facets you can’t even snap to. See below screenshot of identical objects. Left is unselected, middle is selected, right is selected with isocurves on.

@jim
I used DivideAlongCreases and now they look like what sweep1 used to do for me. This may be a settings issue that I inadvertently changed?


(Pascal Golay) #5

Hello - run the CreaseSplitting command and make sure it is set to SplitAlingCreases =yes. That should stop this happening in the future.

-Pascal


(Erikr) #6

That was it. I probably had changed it on accident in an awkward flurry of incorrect keyboard commands.


(Pascal Golay) #7

Hello - my guess is it is nothing you did - there have been cases where this setting is mysteriously toggled, possibly by a plug-in.

-Pascal


(Erikr) #8

Thank you very much Pascal & Jim.