Trouble with picking surfaces

I can’t, but I’ll try to create a similar file with the same problem when I can.

Ok, Here’s a file. I have the most trouble selecting cylindrical shapes. I think.test.3dm (1.3 MB)

How did you create the large block in the file? I cannot select it.

It’s just locked.

My shaded modes are usually set up so that locked objects are transparent. I was simply trying to create a part that is large (similar to the file I couldn’t send earlier) with a smaller part similar to what was in the video I sent earlier.

Here is a video. I’m not sure what’s happening, but I do have trouble with cylinders more than other objects.

I didn’t saw this thread and I made mine.
This a serious problem and it needs to be addressed. It happens in different files with the shaded display mode on.

Hi John,
This is still a big barrier for me. I want to continue to test out & give feedback on Serengeti, but the picking problems are make it so that trying to select things is too tedious. Have you guys identified a culprit? Would it help for me to send more examples?

Turn on isocurve view and only click on those isocurve lines of each face.

Thanks, but that’s not really a solution since I generally work with isocurves turned off. This wasn’t a problem in Rhino 6.

Here is an example, using the same file in Rhino 7 WIP and then in Rhino 6. This example only shows a few clicks, but on normal usage I find that some clicks select the surface behind the one I’m trying to select, some select the correct surface, and most of the clicks select nothing at all.

“Doctor it hurts when I work without isocurves.”

Doctor: “Stop working without isocurves.”

Patient: “No.”

Doctor: “Oh.”

While I admit this is funny, I am with @phcreates on this:
Especially on complex files working with isocurves activated can get very confusing (leaving aesthetic considerations aside).
This is supposed to work as it did in older Rhino versions.
There is a reason why isocurves can be turned of.
What you propose is a workaround, a hack that might be useful in the short term, but this needs to be addressed.

2 Likes

Here is a video with isocurves turned on. (note: in my video, I don’t know how to make it visually apparent that the mouse is being clicked, so I’m literally saying the word ‘click’ each time I click the mouse. I think you’ll find my performance mesmerizing.) I’m not clicking directly on the isocurves, but I shouldn’t have to.

I click on the surface, with isos turned on, 15 times and the surface doesn’t get selected.

yeah…that sucks preeeety bad. It should pick that up in shaded mode.

@jeff any Idea what’s going on here?

I’ve experienced this too last week, on V7 WIP, trying to extract surfaces from polysurfaces in shaded mode. Only thing that worked was picking at the surfaces’ edges.

@theoutside

Kyle, this isn’t a display issue, it’s a picking issue. I would try to get examples that easily reproduce it (Peter’s looks like a good one), and put a YT item together for Mikko… I’d also include Peter’s video.

-Jeff

@phcreates can you send me that model? This is a bug and needs to get fixed asap-

Tech@mcneel.com attn to kyle Houchens

@gustojunk please send a model where you see this happening- We need to fix that asap!

Tech@mcneel.com attn Kyle houchens

bug logged here- https://mcneel.myjetbrains.com/youtrack/issue/RH-58382

1 Like

RH-58382 is fixed in the latest WIP

2 Likes