Trouble in selecting points inside Brep

Hi everyone,
After creating a 3d point grid, I wanted to select only the points inside a closed Brep, but it is keeping one point which is outside…

What am I doing wrong?

Thanks a lot!

forum.gh (56.6 KB)

Opening a GH file that shows NOTHING is disconcerting. There should be something visible.

Why is BrepInc and Dispatch repeated twice? Both results are the same and I don’t see one point outside your brep? Sometimes points can appear outside because they are close to the surface. Point icons are constant in size, regardless of zoom, but if you zoom in close they are actually inside the brep.

I made a small change to the way you used Series to copy layers of points but it has no effect on the results.

BrepInc_2021Jan28a.gh (24.3 KB)

I assume it’s a kind of tolerance problem, anyway, have a try Mesh Inclusion test instead.


forum_reV1.gh (56.5 KB)

Thanks for your answer!
On the image I posted it’s pretty clear that the point is outside the brep!
I repeated them twice in hopes that the second time it would filter that point out, but no luck…

Thank you very much!
Worked like a charm.

I see that point on the image you posted but not in the file I posted. Does that mean I fixed the problem?

Still there! (This is the one you posted)

Are you using R7? It’s not there in R6:

Hardly a day goes by on this forum without reports of R7 anomalies.

Yes I am, but the sneaky point is not visible from that “entrance”.
Please try to rotate it 90º, and if it really is not there, R7 anomaly sounds like the most plausible explication…

I did that, of course, before I posted anything. It’s really not there, the problem appears to be with R7.

I see…
Thank you very much for your time and patience!