Toon Rendering - Interior Setting - Rectangular Light

Hello Everyone,

I am doing a basic toon render of an interior perspective. The toon materials are rendering correctly, however, the final render keeps showing my rectangular light as black. Before I created any toon materials, my rectangular light was invisible and double sided. I confirmed it has something to do with the toon because I created a new rectangular light and also made it Invisible and double sided, and it’s still black in the final render. I am NOT assigning any materials to the Light, of course. Do you think I have to change the render settings?

I never experienced this and I used Toon materials together with area lights in the past.
What version of V-Ray you’re using?

You could try to use invisible emitter materials on rectangle surfaces. Maybe you get the same lighting and your problem is solved.
(I have seen the black lights in the past too. I think it’s an old bug.)

Well I am having the same problem. As you see these trees are invisible to the camera but cast shadows and appear in the reflections. Ground and furniture has a simple gray toon material but show trees in black. Any solution to the problem ? Please see the image below. I use the latest vray V-Ray for Rhinoceros 6 3.60.02